Bug 1381380 - pyanaconda.packaging.NoSuchPackage: xorg-x11-drv-omap
Summary: pyanaconda.packaging.NoSuchPackage: xorg-x11-drv-omap
Status: CLOSED DUPLICATE of bug 1380945
Alias: None
Product: Fedora
Classification: Fedora
Component: comps
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Stephen Gallagher
QA Contact:
URL:
Whiteboard: abrt_hash:227bb9588c77ed872a41d4caedc...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-03 22:49 UTC by BugMasta
Modified: 2016-10-04 12:32 UTC (History)
8 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-10-04 12:32:45 UTC


Attachments (Terms of Use)
File: anaconda-tb (568.85 KB, text/plain)
2016-10-03 22:50 UTC, BugMasta
no flags Details
File: anaconda.log (27.40 KB, text/plain)
2016-10-03 22:51 UTC, BugMasta
no flags Details
File: dnf.librepo.log (49.73 KB, text/plain)
2016-10-03 22:51 UTC, BugMasta
no flags Details
File: environ (482 bytes, text/plain)
2016-10-03 22:51 UTC, BugMasta
no flags Details
File: hawkey.log (2.80 KB, text/plain)
2016-10-03 22:51 UTC, BugMasta
no flags Details
File: lsblk_output (1.31 KB, text/plain)
2016-10-03 22:51 UTC, BugMasta
no flags Details
File: nmcli_dev_list (1.20 KB, text/plain)
2016-10-03 22:51 UTC, BugMasta
no flags Details
File: os_info (451 bytes, text/plain)
2016-10-03 22:51 UTC, BugMasta
no flags Details
File: program.log (21.99 KB, text/plain)
2016-10-03 22:51 UTC, BugMasta
no flags Details
File: storage.log (37.19 KB, text/plain)
2016-10-03 22:51 UTC, BugMasta
no flags Details
File: syslog (240.58 KB, text/plain)
2016-10-03 22:51 UTC, BugMasta
no flags Details
File: ifcfg.log (2.41 KB, text/plain)
2016-10-03 22:51 UTC, BugMasta
no flags Details
File: packaging.log (6.68 KB, text/plain)
2016-10-03 22:51 UTC, BugMasta
no flags Details

Description BugMasta 2016-10-03 22:49:40 UTC
Description of problem:
Select KDE Desktop, or Xfce Desktop when installing rawhide into a VM from x64 Rawhide Fedora Everything Netinstall 20161003 iso.

As soon as you press Done i package election, it bombs out with error, and titlebar of window shows:

pyanaconda.packaging.NoSuchPackage: xorg-x11-drv-omap


Version-Release number of selected component:
anaconda-26.7-1

The following was filed automatically by anaconda:
anaconda 26.7-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.5/site-packages/pyanaconda/packaging/dnfpayload.py", line 540, in _select_group
    raise packaging.NoSuchPackage(str(e), required=True)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/packaging/dnfpayload.py", line 550, in _select_environment
    self._select_group(groupid)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/packaging/dnfpayload.py", line 365, in _apply_selections
    self._select_environment(env, excludedGroups)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/packaging/dnfpayload.py", line 682, in checkSoftwareSelection
    self._apply_selections()
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/gui/spokes/software.py", line 217, in checkSoftwareSelection
    self.payload.checkSoftwareSelection()
  File "/usr/lib64/python3.5/threading.py", line 862, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/threads.py", line 251, in run
    threading.Thread.run(self, *args, **kwargs)
pyanaconda.packaging.NoSuchPackage: xorg-x11-drv-omap

Additional info:
addons:         com_redhat_kdump, com_redhat_docker
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-E-dvd-x86_64-rawh quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.8.0-0.rc8.git3.1.fc26.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        rawhide

Comment 1 BugMasta 2016-10-03 22:50:59 UTC
Created attachment 1206990 [details]
File: anaconda-tb

Comment 2 BugMasta 2016-10-03 22:51:03 UTC
Created attachment 1206991 [details]
File: anaconda.log

Comment 3 BugMasta 2016-10-03 22:51:07 UTC
Created attachment 1206992 [details]
File: dnf.librepo.log

Comment 4 BugMasta 2016-10-03 22:51:08 UTC
Created attachment 1206993 [details]
File: environ

Comment 5 BugMasta 2016-10-03 22:51:10 UTC
Created attachment 1206994 [details]
File: hawkey.log

Comment 6 BugMasta 2016-10-03 22:51:12 UTC
Created attachment 1206995 [details]
File: lsblk_output

Comment 7 BugMasta 2016-10-03 22:51:13 UTC
Created attachment 1206996 [details]
File: nmcli_dev_list

Comment 8 BugMasta 2016-10-03 22:51:15 UTC
Created attachment 1206997 [details]
File: os_info

Comment 9 BugMasta 2016-10-03 22:51:18 UTC
Created attachment 1206998 [details]
File: program.log

Comment 10 BugMasta 2016-10-03 22:51:22 UTC
Created attachment 1206999 [details]
File: storage.log

Comment 11 BugMasta 2016-10-03 22:51:52 UTC
Created attachment 1207000 [details]
File: syslog

Comment 12 BugMasta 2016-10-03 22:51:54 UTC
Created attachment 1207001 [details]
File: ifcfg.log

Comment 13 BugMasta 2016-10-03 22:51:55 UTC
Created attachment 1207002 [details]
File: packaging.log

Comment 14 BugMasta 2016-10-03 22:57:24 UTC
So, to put it bluntly, you can't install Xorg via the current rawhide iso.

Comment 15 BugMasta 2016-10-03 23:05:06 UTC
Additionally, this netinstall iso supposedly passed all tests and was classed "known good"...

Comment 16 Martin Kolman 2016-10-04 10:18:13 UTC
This looks like broken repositories - reassigning to the comps component which should be handling this.

Comment 17 Stephen Gallagher 2016-10-04 12:20:47 UTC
This is

Comment 18 Stephen Gallagher 2016-10-04 12:24:49 UTC
This isn't a comps issue, exactly. The problem is that apparently something has changed how comps is processed between F25 and F26. (Maybe DNF v2?)

Previously, if an item was listed in comps but was not available in the repository, it would just be stripped out. It appears that it's now much stricter and keeps it in.

xorg-x11-drv-omap is included in the @base-x group so that it's pulled in by default on the ARM architecture. However, the package does not exist on any other architecture.

Comment 19 Igor Gnatenko 2016-10-04 12:32:45 UTC

*** This bug has been marked as a duplicate of bug 1380945 ***


Note You need to log in before you can comment on or make changes to this bug.