Bug 138151 - "mkpart(parted command)" command cannot run properly.
"mkpart(parted command)" command cannot run properly.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: man-pages (Show other bugs)
4.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-04 20:45 EST by L3support
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-25 04:02:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description L3support 2004-11-04 20:45:16 EST
Description of problem:

"mkpart" command cannot run properly 
when we tried to create a extended partition 
using "parted(GNU Parted)" command on RHEL4.

Following message are shown
when we specified partition type "extended" or "logical".
The message was shown repeatedly until we specified partition type
"primary".

(parted) mkpart
Partition type?  [primary]? extended
Partition type?  [primary]? logical
Partition type?  [primary]? primary
File system type?  [ext2]?

It is written to manual(man command) as follows.
"part-type should be one of "primary", "logical" or "extended"


Version-Release number of selected component (if applicable):
parted-1.6.12-2

How reproducible:
always

Steps to Reproduce:
1. parted /dev/(device)
2. (parted) mkpart 
3. Partition type?  [primary]? extended(or logical)
4. 

Actual results:
Partition type?  [primary]? extended(or logical)
Partition type?  [primary]? primary
File system type?  [ext2]?

Expected results:
Partition type?  [primary]? extended(or logical)
File system type?  [ext2]?
Comment 1 Bill Nottingham 2004-11-05 00:02:53 EST
What sort of disk label are you using?

EFI partition table doesn't support extended/logical partitions, as
far as I know.
Comment 2 Jeremy Katz 2004-11-08 09:21:51 EST
What was the partition table before your attempt to create a partition?
Comment 3 L3support 2004-11-17 04:39:47 EST
The partition table before my attempt to create a partition is 
as follows.

(parted) p
Disk geometry for /dev/sdb: 0.000-140014.398 megabytes
Disk label type: gpt
Minor    Start       End     Filesystem  Name                  Flags
1          0.017   1000.000  ext2
2       1010.000   2000.000  ext2
3       2000.000   2500.000  ext2
4       2500.000   2550.000  ext3
5       2550.000   2560.000  ext2
(parted) mkpart
Partition type?  [primary]? extended
Partition type?  [primary]? logical
Partition type?  [primary]? primary
File system type?  [ext2]?
Comment 4 Jeremy Katz 2004-11-17 13:02:30 EST
extended and logical partitions aren't supported on GPT -- primary only.
Comment 5 L3support 2004-11-17 23:22:03 EST
Where is the information indicated ?

We looked for the information 
by "man" command and "help(within parted)" command,
but we could not find. 

Moreover, if the information did not indicate
in man page or the result of "help(within parteds)" command,
we think that you need to indicate the information.

Since user can not know the information
by "man" command and "help(within parted)" command,
they think that "parted" command can not run properly.

We want you to indicate the information 
in man page or the result of "help(within parteds)" command. 

Would you indicate the information ?
Comment 6 L3support 2004-12-02 07:37:10 EST
Could you tell me status of problem ?
Comment 7 L3support 2004-12-17 02:28:01 EST
We'd like to know the status of problem.
Comment 8 L3support 2005-01-05 00:26:56 EST
We'd like to know the status of problem.
Comment 9 RHEL4-L3support 2005-01-18 20:41:24 EST
Add RHEL4-L3support team in Japan
Comment 17 Jay Turner 2005-01-25 04:02:27 EST
This isn't a bug in the tools.  The EFI GPT specification clearly states what is
and isn't supported under that partitioning scheme and the parted utility is
enforcing those rules.  The EFI specification is available from Intel at
http://developer.intel.com/technology/efi/download.htm.

Note You need to log in before you can comment on or make changes to this bug.