Bug 1381525 - osp-director-10 : During upgrade OSP9 to OSP10 the INIT step fails due to missing file : major_upgrade_pacemaker_init.yaml
Summary: osp-director-10 : During upgrade OSP9 to OSP10 the INIT step fails due to mis...
Keywords:
Status: CLOSED DUPLICATE of bug 1380670
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 10.0 (Newton)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
: ---
Assignee: Angus Thomas
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-04 11:22 UTC by Omri Hochman
Modified: 2016-10-04 11:44 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-04 11:44:42 UTC


Attachments (Terms of Use)

Description Omri Hochman 2016-10-04 11:22:17 UTC
osp-director-10 : During upgrade OSP9 to OSP10 the INIT step fails due to missing file : major_upgrade_pacemaker_init.yaml


Environment:
------------
instack-undercloud-5.0.0-0.20160929132429.56e65af.el7ost.noarch
python-heat-agent-0.0.1-0.20160920204709.f123aa1.el7ost.noarch
openstack-heat-templates-0.0.1-0.20160920204709.f123aa1.el7ost.noarch
openstack-heat-common-7.0.0-0.20160926200847.dd707bc.el7ost.noarch
python-heat-tests-7.0.0-0.20160926200847.dd707bc.el7ost.noarch
openstack-tripleo-heat-templates-compat-2.0.0-34.1.el7ost.noarch
openstack-tripleo-heat-templates-5.0.0-0.20160929150845.4cdc4fc.el7ost.noarch
puppet-heat-9.4.0-1.el7ost.noarch
openstack-heat-api-7.0.0-0.20160926200847.dd707bc.el7ost.noarch
openstack-heat-engine-7.0.0-0.20160926200847.dd707bc.el7ost.noarch
python-heatclient-1.4.0-0.20160831084943.fb7802e.el7ost.noarch
openstack-heat-api-cfn-7.0.0-0.20160926200847.dd707bc.el7ost.noarch
heat-cfntools-1.3.0-2.el7ost.noarch


Steps: 
------
(1) Upgrade the undercloud from osp9 to osp10 
(2) attempt to update the overcloud follow the steps on https://gitlab.cee.redhat.com/sathlang/ospd-9-to-10-upgrade#controller-and-block-storage-upgrade
(3) run the INIT step


results: 
--------

The INIT step fails due to missing file major_upgrade_pacemaker_init.yaml
""Could not fetch contents for file:///usr/share/openstack-tripleo-heat-templates/extraconfig/tasks/major_upgrade_pacemaker_init.yaml"


[stack@undercloud72 ~]$ source /home/stack/stackrc && openstack overcloud deploy --templates --control-scale 3 --compute-scale 1 --neutron-network-type vxlan --neutron-tunnel-types vxlan --ntp-server 10.5.26.10 --timeout 90 -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml -e network-environment.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/major-upgrade-pacemaker-init.yaml -e /home/stack/overcloud-repos.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/updates/update-from-overcloud-compute-hostnames.yaml
Removing the current plan files
Uploading new plan files
Started Mistral Workflow. Execution ID: 4872584d-32da-4bc5-b87b-e6fe362ba784
Plan updated
Deploying templates in the directory /usr/share/openstack-tripleo-heat-templates
Could not fetch contents for file:///usr/share/openstack-tripleo-heat-templates/extraconfig/tasks/major_upgrade_pacemaker_init.yaml


Stack status  -  UPDATE_FAILED

Comment 1 Omri Hochman 2016-10-04 11:22:50 UTC
Workaround: 
-----------
Run: mkdir -p /home/stack/tht && cd /home/stack/tht/ && swift download overcloud && sudo cp /home/stack/tht/extraconfig/tasks/major_upgrade_pacemaker_init.yaml /usr/share/openstack-tripleo-heat-templates/extraconfig/tasks/major_upgrade_pacemaker_init.yaml

Comment 2 Omri Hochman 2016-10-04 11:44:42 UTC

*** This bug has been marked as a duplicate of bug 1380670 ***


Note You need to log in before you can comment on or make changes to this bug.