Bug 138156 - unable to print CJKI characters in UTF-8
unable to print CJKI characters in UTF-8
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-05 01:12 EST by Lawrence Lim
Modified: 2014-03-25 20:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-17 10:43:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ps file with korean characters in the message content (34.87 KB, text/postscript)
2004-11-05 01:14 EST, Lawrence Lim
no flags Details
ps file generated from thunderbird (35.49 KB, application/postscript)
2005-03-31 20:14 EST, Lawrence Lim
no flags Details
email message containing strings from all 8 locales. (1.80 KB, message/rfc822)
2005-03-31 20:15 EST, Lawrence Lim
no flags Details
The postscript file of saved file, with CJKI text (142.75 KB, application/postscript)
2007-01-15 05:42 EST, Ramakrishna Reddy Yekulla
no flags Details

  None (edit)
Description Lawrence Lim 2004-11-05 01:12:33 EST
Description of problem:


Version-Release number of selected component (if applicable):
thunderbird-0.8.0-9

How reproducible:
Always

Steps to Reproduce:
1.in gnome-terminal, LANG=ja_JP.UTF-8 MOZ_ENABLE_PANGO=1 thunderbird
2.compose a new mail, in the message content, enter 'aka' using IIIMF
input method
3.save the message to draft folder
4.print the message from the draft folder
  
Actual results:
Print out squares

Expected results:
Content of the message can be printed.

Additional info:
Comment 1 Lawrence Lim 2004-11-05 01:14:44 EST
Created attachment 106199 [details]
ps file with korean characters in the message content
Comment 2 Jens Petersen 2005-03-18 03:54:17 EST
This look ok for me for Japanese with thunderbird-1.0 at least.
Comment 3 Christopher Aillon 2005-03-31 05:28:26 EST
Can this be closed then?
Comment 4 Lawrence Lim 2005-03-31 20:13:55 EST
Hi Chris,
I have tried thunderbird-1.0.2-1.4.1 in CJKI (8 locales) and unfortunately, all
8 locales still are not able to print properly. The output of the printing is
still empty square.

I have attached the message together with the ps file containing strings from
all 8 locales. Hope it helps.


Thanks.

--
Locale included:
zh_TW
ja_JP
ko_KR
bn_IN
gu_IN
hi_IN
pa_IN
ta_IN
Comment 5 Lawrence Lim 2005-03-31 20:14:54 EST
Created attachment 112553 [details]
ps file generated from thunderbird
Comment 6 Lawrence Lim 2005-03-31 20:15:39 EST
Created attachment 112554 [details]
email message containing strings from all 8 locales.
Comment 7 Jens Petersen 2005-05-16 10:25:22 EDT
Lawrence, perhaps it has to be utf-8 not to print??

At least ja messages in ISO-2022-JP print ok for me
with thunderbird-1.0.2-1.3.2 on FC3.
Comment 8 Jens Petersen 2005-05-16 11:15:08 EDT
Is this a duplicate of bug 126265?
Comment 10 Akira TAGOH 2006-02-21 03:53:29 EST
Comment #7:
This happens if the message body is encoded as UTF-8. but UTF-8 subject is
printable.

FYI, This looks to me like get fixed in 1.5-3 in FC5. but still appears on FC4.
changing version then.
Comment 11 Matěj Cepl 2007-01-11 10:44:44 EST
Hi, Lawrence,

could you test this bug for me? Is it still present in the current relase of FC6?

Thanks
Comment 12 A S Alam 2007-01-12 07:00:23 EST
Hi,
it is working for Rawhide release of thunderbird, tested with following version:
thudnerbird-1.5.0.9-5.fc7
Comment 13 Ramakrishna Reddy Yekulla 2007-01-15 05:41:01 EST
Version Number tested against ::
thunderbird-1.5.0.9-2.fc6
homer@vanilla ~]$ rpm -qa|grep scim
scim-libs-1.4.4-37.fc6
scim-bridge-0.4.7-1.fc6
scim-m17n-0.2.0-6.fc6
scim-anthy-1.2.2-1.fc6
scim-1.4.4-37.fc6

[homer@vanilla ~]$ rpm -qa|grep thunderbird
thunderbird-1.5.0.9-2.fc6

Steps to reproduce
1.LANG=ja_JP.UTF-8 MOZ_ENABLE_PANGO=1 thunderbird
2. Thunderbird -> Compose Mail
3. Activate SCIM -> [Ctrl Space]
4. Choose Japanese -> Anthy
5. Enter the key sequence "aka"
using the scim-anthy input method
6. Save the composed mail to drafts
7. print the message

Observed::
No square boxes are appearing in the output file. attaching the output of the
saved draft file

 
Comment 14 Ramakrishna Reddy Yekulla 2007-01-15 05:42:38 EST
Created attachment 145563 [details]
The postscript file of saved file, with CJKI text
Comment 15 Matěj Cepl 2007-01-17 10:29:20 EST
Lawrence? Can you confirm that it has been fixed?
Comment 16 Lawrence Lim 2007-01-17 10:43:55 EST
Resolving based on Comment #12 & #13. 

Note You need to log in before you can comment on or make changes to this bug.