Bug 138164 - GNOME panel window applet is not aware of Bluecurve theme
GNOME panel window applet is not aware of Bluecurve theme
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
3
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-05 03:36 EST by Joachim Frieben
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-27 07:08:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 126081 None None None Never

  None (edit)
Description Joachim Frieben 2004-11-05 03:36:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020 Epiphany/1.4.4

Description of problem:
After opening a gnome-terminal window, there is a corresponding entry
in the also active window list applet of gnome-panel. However, the
icon used to identify the application is the ugly stock GNOME icon.
This discrepancy becomes particularly apparent when a launch button
for gnome-terminal has been added to the panel, because then, there
are 2 different icons to designate a single application - the launch
button using the Bluecurve theme, and the window list applet using the
stock GNOME default theme.

Version-Release number of selected component (if applicable):
gnome-panel-2.8.1-3

How reproducible:
Always

Steps to Reproduce:
1. Launch window list applet of GNOME panel.
2. Launch GNOME terminal.
3. See the stock GNOME button on the corresponding tab.
    

Actual Results:  The stock GNOME terminal icon is displayed.

Expected Results:  The Bluecurve icon should be used, at least, when
the default Bluecurve theme is active.

Additional info:

A quick and dirty hack is to replace
/usr/share/pixmaps/gnome-terminal.png of gnome-terminal-2.7.3-1 by
/usr/share/icons/Bluecurve/48x48/apps/icon-terminal.png of
redhat-artwork-0.117-1. The icon needs to be cropped to about 41x41
pixels. Otherwise the border around the terminal image is too wide and
the terminal icon on the appears too small.
Comment 1 Marco Pesenti Gritti 2004-11-05 12:15:20 EST
UPSTREAM

http://bugzilla.gnome.org/show_bug.cgi?id=126081
Comment 2 Joachim Frieben 2004-11-06 09:51:13 EST
I reported the bug for 'gnome-panel' focusing on the particular
example of 'gnome-terminal'. However, the observation is a general
one. Add for example 'gedit' to the GNOME panel and launch the
application. The launch button displays the Bluecurve icon, the
windows list tab the stock GNOME 'gedit' icon, whereas it should use
the Bluecurve icon. Hence, this is *not* a genuine 'gnome-terminal'
problem - it is a 'gnome-panel' one. As the title of the bug report
says: "GNOME panel window applet is not aware of Bluecurve theme" -
that's exactly what the problem is about. It is therefore a
'gnome-panel' flaw, and the bug should be reopened unless there is a
general solution to make 'gnome-panel' theme-aware.
Comment 3 Mark McLoughlin 2005-04-27 07:08:41 EDT
Joachim: Marco was right to move this upstream.

The issue here is that the window list display whichever icon is specified in
the _NET_ICON X property on the window.

So, if the wrong icon is displayed for a given, its because the app is setting
the wrong icon.

In this case, gnome-terminal is setting the icon to the one display in the
preferences dialog (go to Edit->Current Profile) and that icon isn't themed.

Note You need to log in before you can comment on or make changes to this bug.