Bug 138183 - Does not display umlauts with a configured german keyboard layout
Does not display umlauts with a configured german keyboard layout
Status: CLOSED DUPLICATE of bug 138618
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-05 06:59 EST by Carsten Klein
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-28 09:03:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Shows the described bug (3.64 KB, text/plain)
2004-11-05 07:00 EST, Carsten Klein
no flags Details
Shows the described bug (3.64 KB, image/jpeg)
2004-11-05 07:00 EST, Carsten Klein
no flags Details

  None (edit)
Description Carsten Klein 2004-11-05 06:59:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040929

Description of problem:

I cannot enter umlauts into any document. The previous version FC3T2
and the included openoffice.org version did work, however.



Version-Release number of selected component (if applicable):
rhopenoffice-1.1

How reproducible:
Always

Steps to Reproduce:
1. Install FC3T3 and configure a deDE keyboard layout
2. Startup openoffice.org writer
3. enter umlauts
    

Actual Results:  
The umlauts are displayed as can be seen on the attached picture.



Expected Results:  
Correctly displayed umlauts.

Additional info:


I have de-installed the rpm - packages for openoffice.org-1.1.2
and installed it anew with an installation archive I have downloaded
earlier from the OpenOffice.org website.

The same happens. It seems that openoffice.org produces this bug, as
no other application that uses the GTK does fail to correctly display
umlauts.
Comment 1 Carsten Klein 2004-11-05 07:00:33 EST
Created attachment 106211 [details]
Shows the described bug
Comment 2 Carsten Klein 2004-11-05 07:00:44 EST
Created attachment 106212 [details]
Shows the described bug
Comment 3 Dan Williams 2004-11-05 09:30:42 EST
Can you do the following?

1) open a terminal
2) type 'gkb_xmmap de'
3) type '/usr/bin/oowriter'
4) hit the 'ö' key (US keyboard's ';' character)

Can you still not see the umlaut?  I cannot reproduce this on FC3
using this procedure...  Also, are you running any input servers, like
iiimf/htt/Canna/FreeWnn?

(I can't reproduce by going to the Keyboard preference applet and
making a German Basic layout the current layout either...)
Comment 4 Carsten Klein 2004-11-05 10:42:07 EST
Thanks for the hint, but after I have re-installed everything from
scratch, switching back to FC3T2, I experience the very same problems
now with a former working installation basis.

Heck, I should have waited prior re-installing and read your ingenous
and valuable hint reg. additional input servers. That did the trick, I
just disabled kanna and iiim and now it works as expected.

I think we can close this bug but should nonetheless keep in mind that
Openoffice has problems with additional input servers, okay?
Comment 5 Carsten Klein 2004-11-05 10:43:39 EST
Now that I have so much excercise with it, I will continue
re-installing FC3T3 ... ,-) and de-escalete it again to "absolut
stressfrei"



Comment 6 Dan Williams 2004-11-05 10:56:30 EST
Well, its really a bug since it should work fine with input servers
running int he background, I couldn't reproduce this with them running
though.  Did you just start them up?  What was the value of your
GTK_IM_MODULE environment variable?  I'd like to figure this out so I
can reproduce it.
Comment 7 Carsten Klein 2004-11-05 11:34:18 EST
Well, the services (canna etc.) are started during the startup process.
I just restarted the system and forgot to disable the services from
the respective runlevels and the problem persists. I will now remove
them from the respective runlevels in order to get OOo working again,
besides I do not really need these services ;-)

Note  that I also reported the bug to the openoffice bug-tracker, so
that they also may have a look at the problem, and, as it only exists
in openoffice so far, I presume that it is more like their
responsibility rather than anyone else's, or so...

The environment variable you are talking about does not exist on my
system - however I am just running KDE and that does not necessarily
rely on the GIMP toolkit.
Comment 8 Petr Šimon 2005-01-21 05:40:51 EST
I reproduce it on FC3 (fully updated).
I would say that all this is UTF-8 realted, cf also #132541. When I tried
de_DE.iso88591 it worked well. Only seems to be the problem KDE.
Comment 9 Dan Williams 2005-02-28 12:18:56 EST

*** This bug has been marked as a duplicate of 138618 ***
Comment 10 Caolan McNamara 2005-04-28 09:03:10 EDT
close as duplicate

Note You need to log in before you can comment on or make changes to this bug.