Bug 138243 - Custom kernel install
Summary: Custom kernel install
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-06 01:49 UTC by Hans Strijker
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2004-11-08 14:44:15 UTC


Attachments (Terms of Use)

Description Hans Strijker 2004-11-06 01:49:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.1.4322)

Description of problem:
I would love to see an option that would let anaconda install 
packages from source on a customised kernel.
I would love to see it being possible to configure a kernel the way I 
would like to have it, save it on a seperate small partition, usb 
stick or floppy drive and then install fedora using that kernel. 
Perhaps it would then also be possible to make anaconda use custom 
drivers like the proper nVidia drivers from thesame 
partition/disk/usb-device.
I have no idea how much work this would be since I'm not much of a 
programmer, just a little bit more then a regular pc user.

With regards,
Hans Strijker

Version-Release number of selected component (if applicable):
-all-

How reproducible:
Always

Steps to Reproduce:
1.install a distro equipped with anaconda
2.
3.
    

Additional info:

Comment 1 Jeremy Katz 2004-11-08 14:44:15 UTC
anaconda already has support for driver disks for storage and network
drivers that are needed for during the install.  Adding a build
environment isn't practical, though, due to the space considerations.
 Anaconda will get your system installed and then you can do whatever
you want.


Note You need to log in before you can comment on or make changes to this bug.