Bug 138255 - missing return type on function
missing return type on function
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-06 04:59 EST by David Binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-09 05:42:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Binderman 2004-11-06 04:59:01 EST
Description of problem:

I just tried to compile package vim-6.3.028-2 from 
Redhat Fedora Core 3 Test 3.

The compiler said

os_unix.c(2335): remark #117: non-void function "mch_copy_sec" should
return a value
os_unix.c(2351): remark #117: non-void function "mch_copy_sec" should
return a value
os_unix.c(2356): remark #117: non-void function "mch_copy_sec" should
return a value
os_unix.c(2364): remark #117: non-void function "mch_copy_sec" should
return a value
os_unix.c(2378): remark #1011: missing return statement at end of
non-void function "mch_copy_sec"

Suggest change return type of function mch_copy_sec to void.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Karsten Hopp 2004-11-08 06:13:28 EST
I cannot reproduce this with the latest vim-6.3.030-3.
Which compiler did you use and on which distribution, i.e. did you try
to recompile the package for FC1 or FC2 ?
Comment 2 David Binderman 2004-11-08 12:27:06 EST
>Which compiler did you use

Intel 8.1, although you could use the Mark 1 Eyeball.

>on which distribution

Like the bug report says: Fedora Core 3 Test 3
Comment 3 Karsten Hopp 2004-11-08 13:32:09 EST
gcc is smarter than Intels compiler here and detects that this 
function never returns a value. Please work with the upstream 
maintainers if you want ISO C vim sources or ask Intel for a smarter 
compiler. 
Comment 4 David Binderman 2004-11-08 15:14:40 EST
>gcc is smarter than Intels compiler here

Good comedy !

>Please work with the upstream maintainers if you want ISO C vim sources

Righto. So you are saying there is a known bug in the vim sources,
but you won't fix it ?

>ask Intel for a smarter compiler.

I already have. 
Comment 5 Karsten Hopp 2004-11-09 05:42:51 EST
There is a one word ('void') omission in the vim sources which only
results in a bug when you try to compile vim with an unsupported
compiler. Our compiler does the right thing here. If you wan't to get
this fixed, send a report to the upstream maintainers, this is not a
bug in Fedora Core.

Note You need to log in before you can comment on or make changes to this bug.