Bug 13826 - Colours swap with permedia II
Colours swap with permedia II
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86-Servers (Show other bugs)
7.3
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-12 16:02 EDT by Richard D. Payne
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-13 13:56:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard D. Payne 2000-07-12 16:02:12 EDT
Running an Oxygen ACX card (AGP Permedia II) in a UP1000. I ran
Xconifgurator to
config the card - 1152x864 at 24bpp. X starts and runs succesfully. However
after several
minutes the blue and red colours appear to swap. The blue RedHat background
becomes
red (along with the blue titlebars etc....) and anything red (for example I
had netscape
up, displaying www.alphalinux.org) get changed to blue....including the
RedHat logo
on the default home page.

Swapping to vc-1 and then back seems to clear the problem.
Comment 1 Peter Petrakis 2000-07-14 09:46:44 EDT
Also sometimes the monitor will unpredictibly blank out. Switching to a VT and
back again brings it back to normal.
Comment 2 Richard D. Payne 2000-07-14 09:48:56 EDT
Yes I've seen this as well (and was just about to file a bug on it). Disabling
dpms for the
xserver seems to stop it from doing this.

xset -dpms
Comment 3 Mike A. Harris 2001-03-19 17:45:18 EST
Try using XFree86 4.x instead by doing:

Xconfigurator --preferxf4

If that doesn't make things better, please try our latest XFree86 release.
much has changed since this bug was reported.  XFree86-4.0.3-1 is now
available.

ftp://people.redhat.com/mharris

You need to get Mesa as well.
Does this fix it for you?
Comment 4 Mike A. Harris 2001-04-10 01:02:05 EDT
A *MAJOR* new update to the Permedia driver has just been incorporated
into XFree86-4.0.3-8.  The patches are from Compaq, and fix numerous
problems on Alpha, as well as other platforms.  These packages are available
for download at:   http://people.redhat.com/mharris
Please close the bug report after confirming that it does in fact fix the
problem for you, and ensure that you fill out new bug reports if you encounter
any new errors.  Thanks.
Comment 5 Richard D. Payne 2001-04-10 08:16:16 EDT
OK, I'll try the updates ASAP, though it may be a few days before I get
results back.
Comment 6 Mike A. Harris 2001-04-13 13:55:59 EDT
I mistakenly gave a bad URL above.  ;o(  The proper URL is:

ftp://people.redhat.com

Not http.  Please try out the latest code and let me know if this problem is
fixed now.
Comment 7 Mike A. Harris 2001-04-25 01:19:48 EDT
I've had confirmation that the above driver works now.

XFree86-4.0.3-9 and higher which should appear in rawhide shortly.

Note You need to log in before you can comment on or make changes to this bug.