Bug 138260 - xcursor dependency missing
xcursor dependency missing
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-06 08:26 EST by Steve Chaplin
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-25 13:35:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Chaplin 2004-11-06 08:26:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
When trying to install 'xsvg' I get the error:
"checking for libsvg-cairo >= 0.1.3 xcursor... Package xrender was not
found in the pkg-config search path.
Perhaps you should add the directory containing `xrender.pc'
to the PKG_CONFIG_PATH environment variable
Package 'xrender', required by 'Xcursor', not found"

The software requires xcursor, it checks the file
/usr/lib/pkgconfig/xcursor.pc
and reads the line "Requires: xrender"
it then looks for the file
/usr/lib/pkgconfig/xrender.pc
does not find it and terminates with an error.

From looking at the output of
rpm -ql xorg-x11-devel|grep -i xrender
it looks like xorg-x11-devel does include xrender, but it does not
provide the "xrender.pc" file that is required by pkg-config



Version-Release number of selected component (if applicable):
xorg-x11-devel 6.7.0-02  (and also -09)

How reproducible:
Always

Steps to Reproduce:
1.pkg-config --modversion xcursor
2.
3.
    

Actual Results:  Package xrender was not found in the pkg-config
search path.
Perhaps you should add the directory containing `xrender.pc'
to the PKG_CONFIG_PATH environment variable
Package 'xrender', required by 'Xcursor', not found

Expected Results:  xcursor version should be reported

Additional info:
Comment 1 Mike A. Harris 2004-11-25 10:21:56 EST
Please file a bug report in X.Org bugzilla concerning missing
pkg-config .pc files.  Once X.Org has reviewed your request and
implemented pkg-config files in their standard release, then
we will include them in future OS releases, and potentially
future Fedora Core updates as well.

For the time being however, applications should not rely on the
existance of pkg-config .pc files for any X11 included libraries,
since X.Org does not supply these files.

Once you have filed your bug report at http://bugs.freedesktop.org,
in the xorg component, please paste the URL here, and we will track
the issue upstream and review any upstream changes for consideration
in our update releases.

Thanks.
Comment 2 Steve Chaplin 2004-11-25 13:28:33 EST
This problem has already been fixed - Fedora 3 has the xrender.pc file
that was missing in Fedora 2.
Comment 3 Mike A. Harris 2004-11-25 13:35:44 EST
Ah, ok.  Looks like Xorg added it for a couple of libraries.

Thanks for the update.  Setting bug status to "CURRENTRELEASE"
of Fedora Core 3.

As an additional note to others who may stumble upon this bug
when searching for similar problems in the future:

If anyone else happens to find other libs missing .pc files
though, please report them directly to X.Org at
http://bugs.freedesktop.org, so it gets fixed upstream.  That
way people are always basing their build scripts off the official
upstream standard, and not what individual distributions are
shipping.

Thanks in advance.

Note You need to log in before you can comment on or make changes to this bug.