Bug 138270 - Segmentation fault
Segmentation fault
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc4 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-06 22:18 EST by John Ellson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-08 03:34:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
description of bug sent to gcc-bugs@gnu.org (190.77 KB, text/plain)
2004-11-06 22:20 EST, John Ellson
no flags Details

  None (edit)
Description John Ellson 2004-11-06 22:18:41 EST
Description of problem:
Segmentation fault

See copy of report sent to gcc-bugs@gnu.org attached next

This file compiled OK with gcc4-4.0.0-0.5

Version-Release number of selected component (if applicable):
gcc4-4.0.0-0.9
glibc-2.3.3-75

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 John Ellson 2004-11-06 22:20:27 EST
Created attachment 106253 [details]
description of bug sent to gcc-bugs@gnu.org
Comment 2 John Ellson 2004-11-06 22:31:18 EST
Andrew Pinski reported that the problem is not reproducible with 
gcc version 4.0.0 20041102.  Perhaps just the Redhat version 20041028
is bad?

-------------------mail from Andrew Pinski--------------------------
I cannot reproduce it with:
Reading specs from
/home/gates/pinskia/linux/lib/gcc/i686-pc-linux-gnu/4.0.0/specs
Configured with: /home/gates/pinskia/src/gnu/gcc/src/configure
--target=i686-pc-linux-gnu --host=i686-pc-linux-gnu
--enable-__cxa_atexit --enable-languages=c++,objc,java
--prefix=/home/gates/pinskia/linux --enable-threads=posix --enable-shared
Thread model: posix
gcc version 4.0.0 20041102 (experimental)

I think you should try a newer compiler first and then file a correct
bug report.
Read http://gcc.gnu.org/bugs.html for the directions on filing a
correct bug report.

Thanks,
Andrew Pinski
Comment 3 Jakub Jelinek 2004-11-08 03:34:15 EST
gcc 4 is still in heavy development, so one should really always verify
CVS HEAD has the problem too before reporting, especially when using rawhide package of it.
This ICE was specific to gcc4-4.0.0-0.9, was not present in gcc4-4.0.0-0.8
and is gone in gcc4-4.0.0-0.10 as well.

Note You need to log in before you can comment on or make changes to this bug.