Bug 138278 - Installer crashes while proposing new parttion scheme
Installer crashes while proposing new parttion scheme
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-07 05:26 EST by Yuri Colombi
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-08 10:07:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda dump with the details of the exeption (34.27 KB, text/plain)
2004-11-07 05:27 EST, Yuri Colombi
no flags Details

  None (edit)
Description Yuri Colombi 2004-11-07 05:26:07 EST
Description of problem:
Installation crashes while proposing the automatic partitioning

How reproducible:
On my Dell Inspiron 4000, with an existing Windows 2000 parition and
Linux (Mandrake 10) partitions

Steps to Reproduce:
1. Boot on the instalation CD
2. Choose English as installation language
3. Choose French as keyboard
4. Choose Dell laptop 1027X768 Laptop Display Panel
5. Keep Personal Desktop option
6. Keep "Automatically partion"
7. Keep "Remove all Linux partitions on this system" and check the
option to "Review (and modifiy if needed) the partitions created
  
Actual results:
Installer crashes (Exeption occured)

Expected results:
The next screen with the partition proposal
Comment 1 Yuri Colombi 2004-11-07 05:27:32 EST
Created attachment 106257 [details]
anaconda dump with the details of the exeption
Comment 2 Yuri Colombi 2004-11-07 06:07:26 EST
I forgot to say that after the step 7, I saw a confirmation Windows,
and that I said "OK": the Exeption occured just after this click.

I repetaed the crash 3 times. I tried a 4th test without checking the
option Review (and modifiy if needed) the partitions created and I had
the same result.

I have a single HD of 10 GB. I think the existing Linux partition are
4 GB big. The screen after having choose Automatically partition show
the single selected drive:
hda 9586 MB HITACHI_DK23CA-10
To go around the bug, I choose a manual Druid partitiong, which show
/dev/hda2 as ext3 with 102 MB
/dev/hda3 as ext3 with 2832 MB
and an extended /dev/hda4 swap of 510 MB
I was enable to continue the installation process.
(I skipped the option to check the media in the very beginning of the
install process) 
Comment 3 Jeremy Katz 2004-11-08 10:07:23 EST
This should be fixed in FC3

Note You need to log in before you can comment on or make changes to this bug.