Bug 138283 - from kernel-2.4.21-21 to kernel-2.4.21-23 agpgart patch brokes boot
from kernel-2.4.21-21 to kernel-2.4.21-23 agpgart patch brokes boot
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Larry Woodman
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-07 08:10 EST by Pasi Pirhonen
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-08 14:09:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
reverse patch for mods from -21 to -23 (1.79 KB, application/octet-stream)
2004-11-07 08:11 EST, Pasi Pirhonen
no flags Details

  None (edit)
Description Pasi Pirhonen 2004-11-07 08:10:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040123 Debian/1.6-1.he-1

Description of problem:
reversing attached patch will make for example Asus SK8N (NForce3) and
Epox 8HDA-series (KT800) to boot again. Tyan dual-opteron wasn't
affected even w/o reversing patches.


Version-Release number of selected component (if applicable):
kernel-2.4.21-23

How reproducible:
Always

Steps to Reproduce:
1. install the latest beta kernel
2.
3.
    

Actual Results:  The system panics pretty early in boot

Expected Results:  normal boot

Additional info:

i even tried to tweak BIOS settings, but that didn't help. That
NForce3 did need before the 'noapic' parameter, but with
kernel-2.4.21-23 it's finally first time working (with the reversed
agpgart) w/o any extra boot parameters. Sure FC2/FC3 has booted, but i
remember seeing kernel just applying noapic on the fly when NFofrce3
was detected.

as a side note, the forcedeth seems to be working too, so i don't have
to maintain that myself anymore :)
Comment 1 Pasi Pirhonen 2004-11-07 08:11:44 EST
Created attachment 106259 [details]
reverse patch for mods from -21 to -23
Comment 2 Ernie Petrides 2004-11-08 14:09:40 EST

*** This bug has been marked as a duplicate of 137819 ***
Comment 3 Ernie Petrides 2004-11-10 21:30:33 EST
A fix for this problem has just been committed to the RHEL3 U4
patch pool this evening (in kernel version 2.4.21-24.EL).
Comment 4 John Flanagan 2004-12-20 15:56:56 EST
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-550.html

Note You need to log in before you can comment on or make changes to this bug.