Bug 138298 - language for httpd-manual does not work out of the box
language for httpd-manual does not work out of the box
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-07 15:16 EST by Joe Acosta
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-08 15:17:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Acosta 2004-11-07 15:16:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041001
Firefox/0.10.1

Description of problem:
Description of problem: After reading the apache web site, they state
that the mod_negotiation is supposed to handle different lanaguages. 
The manual suggests using a index.html.var file as a type-map file. 
In looking at the httpd manual there is a index.html that is the type
map file.   

After I moved all the index.html files to be index.html.var files it
now works and shows me the correct language page.





Version-Release number of selected component (if applicable):
httpd-manual-2.0.51-2.7

How reproducible:
Always

Steps to Reproduce:
1. install httpd
2. install httpd-manual-2.0.51-2.7
3. go to the <your server>/manual 
4. you get the output of the type-map file
    

Actual Results:  URI: index.html.de Content-Language: de Content-type:
text/html; charset=ISO-8859-1 URI: index.html.en Content-Language: en
Content-type: text/html; charset=ISO-8859-1 URI: index.html.es
Content-Language: es Content-type: text/html; charset=ISO-8859-1 URI:
index.html.ja.euc-jp Content-Language: ja Content-type: text/html;
charset=EUC-JP URI: index.html.ko.euc-kr Content-Language: ko
Content-type: text/html; charset=EUC-KR URI: index.html.ru.koi8-r
Content-Language: ru Content-type: text/html; charset=KOI8-R


Expected Results:  should list the index.html.en file instead as html


Additional info:
Comment 1 Joe Acosta 2004-11-07 15:28:11 EST
Workaround
as root:
> cd /var/www/manual  && find ./ -name "*.html" -exec mv {} {}.var \;
> service httpd restart
Comment 2 Joe Orton 2004-11-08 11:09:56 EST
Have you removed the section from the default httpd.conf which looks like:

<Directory "/var/www/manual">
...
    <Files *.html>
        SetHandler type-map
    </Files>

Comment 3 Joe Acosta 2004-11-08 14:04:26 EST
I've never seen that in my httpd.conf file.  Any idea which version of
RH / Fedora that came in?  

I've basically been using the same httpd.conf for a while now, and
that's never existed.  IE: I've upgraded this system from RH 7.0 or
7.1 to fc 2.   
Comment 4 Joe Orton 2004-11-08 15:17:41 EST
It's been in the stock httpd.conf since FC1.  So yes, /manual/ won't
work if you use an old httpd.conf.  That's actually fixed in FC3,
since the <Directory> segment in question has been moved to
/etc/httpd/conf.d/manual.conf, as it happens.

Note You need to log in before you can comment on or make changes to this bug.