Bug 138305 - Crashes when attempting to install a package from an iso image
Crashes when attempting to install a package from an iso image
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-packages (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-07 19:45 EST by William Shotts
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.2.25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-20 02:38:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Shotts 2004-11-07 19:45:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
When invoked on the command with --isodir=<path>,
system-config-packages crashes with the following output:

# system-config-packages --isodir=/home/cd_images/fedora_core_3
Traceback (most recent call last):
  File "/usr/share/system-config-packages/MainWindow.py", line 160, in ?
    im = get_method(args)
  File "/usr/share/system-config-packages/config.py", line 57, in
get_method
    return method.LoopbackIsoInstallMethod(isodir)
  File "/usr/share/system-config-packages/method.py", line 343, in
__init__
    self.discImages = findIsoImages(tree)
  File "/usr/share/system-config-packages/method.py", line 859, in
findIsoImages
    raise RuntimeError, "Unable to create directory to mount CDs"
RuntimeError: Unable to create directory to mount CDs


Version-Release number of selected component (if applicable):
system-config-packages-1.2.20-1

How reproducible:
Always

Steps to Reproduce:
1. Copy FC3 .iso images to a directory
2. invoke system-config-packages --isodir=<path to iso images>
3. system-config-packages crashes
    

Actual Results:  system-config-packages crashes with the output above.

Expected Results:  system-config-packages mounts iso images as
documented in /usr/share/doc/system-config-packages-1.2.20/README

Additional info:

I have tried this with SELinux on and off by setting setenforce 0.
Comment 1 Jeremy Katz 2004-11-08 10:18:38 EST
Does it work if you edit /etc/system-config-packages.method and put
MOUNTPOINT=/mnt in there?
Comment 2 William Shotts 2004-11-08 10:42:03 EST
That file did not exist so I created it and put "MOUNTPOINT=/mnt" in
it.  After I did that, it worked.  I was able to add a package from an
iso image.
Comment 3 Jeremy Katz 2004-11-08 10:55:12 EST
Do you have anything mounted on or in /mnt?
Comment 4 William Shotts 2004-11-08 11:30:16 EST
Yes and no.  On my first attempt, I had an NFS mount to the iso images
on another machine and mounted the iso directory's parent on /mnt. 
After that didn't work (system-config-packages crashed as described),
I copied the iso images to the local machine and umounted the NFS file
system.  When pointed to the local directory, system-config-packages
continued to crash.

I noticed that the mount command continued to say that the NFS file
system was mounted on /mnt even after the umount.  Running umount
again resulted in "/mnt not mounted" messages.  It seemed all hosed up
at that point with multiple loop devices mounted and iso9660 systems
mounted on the loop devices, strange messages, etc., etc.

I rebooted the machine (it had abunch of errors during the shutdown
regarding being unable to unmount the loop devices) and it came back
up in a better state.  I renamed the
/etc/system-config-packages.method file and ran system-config-packages
again, pointing it to the local ios dierctory and it worked.

One thing I notice is when you bring up system-config-packages and
then click the quit button, the iso image remains mounted.  Shouldn't
 it go away once the application is terminated?  
Comment 5 Jeremy Katz 2004-11-08 11:36:03 EST
Okay, this should be better in CVS
Comment 6 Marius Andreiana 2005-08-20 02:38:56 EDT
Closing per comment #5 and no feedback.

Note You need to log in before you can comment on or make changes to this bug.