Bug 138319 - "print(parted command)" command cannot run properly.
Summary: "print(parted command)" command cannot run properly.
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: parted   
(Show other bugs)
Version: 4.0
Hardware: ia64 Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-08 08:38 UTC by L3support
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-21 01:01:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description L3support 2004-11-08 08:38:28 UTC
Description of problem:

We create a primary partition with an "ext2" file system
using "mkpart(parted command)" command on RHEL4.

"print" command cannot run properly 
when we confirmed that 
it is in the partition table correct after creating the partition, 

The file system type of creating the partition was blank.
The result is as follows.
(The minor number 4 is partition which we created)

(parted) print
Disk geometry for /dev/sdb: 0.000-140014.398 megabytes
Disk label type: gpt
Minor    Start       End     Filesystem  Name                  Flags
1          0.017   1000.000  ext2
2       1010.000   2000.000  ext2
3       2000.000   2500.000  ext2
4       2500.000   2520.000


We know that "mkpart" command make a partition 
without creating a new file system.
But we can specify file system type as argument of "mkpart" command.

If "print" command run properly,
What is the purpose which specifies file system type ?

Version-Release number of selected component (if applicable):
parted-1.6.12-2

How reproducible:
always

Steps to Reproduce:
1. parted /dev/(device)
2. (parted) mkpart 
3. Partition type?  [primary]? primary
4. File system type?  [ext2]? ext2
5. Start? (Start)
6. End? (End)
7. (parted) print

Actual results:

(parted) print
-- excerpt --
4       2500.000   2520.000  

Expected results:

(parted) print
-- excerpt --
4       2500.000   2520.000  ext2

If "print" run properly,
What is the purpose which specifies file system type ?

Comment 1 L3support 2004-11-24 01:16:41 UTC
Could you tell me status of this problem ?

Comment 2 Andrew Clausen 2004-11-24 01:25:19 UTC
This is not a bug, it's a feature :)

Even though the partition type is "ext2", there is no file system on
it.  Parted only displays the type of file system found (if any).

Comment 3 L3support 2004-11-25 02:01:00 UTC
Thank you for your comment.

We think that it's a feature.
"mkpart" command only make a partition.

Then, why can we specify file system type 
as argument of "mkpart" command ?

What is the purpose which specifies file system type ?

If the act(specifying) is meaningless,
we wish that the information is indicated
in man page or the result of "help(within parteds)" command.ã

Comment 4 Andrew Clausen 2004-11-26 12:22:23 UTC
Partition tables can store the type of file system contained in the
partition.  When you use "mkpart", Parted will store this type in this
way.

Just because you can't see it doesn't mean it's meaningless ;)

Can you suggest a new wording for the Parted online help text?

Comment 5 L3support 2004-11-29 07:09:37 UTC
Thank you for your quick comment.

Is what you say that specifying is meaning ?

Why dose "parted" store flie system type, 
when we use "mkpart" ?
--------------------------------------------------------------
>when you use "mkpart", Parted will store this type in this
>way.
--------------------------------------------------------------

We can create file system with "ext2",
even if we specify file system type "ext3" 
as argument of "mkpart" command.

And "print(within parted)" only showed file system type 
that is created.

If we can't only understand how to use "mkpart",
could you teach me that specifying has a meaning ?
(with example)

Comment 6 L3support 2004-12-13 07:10:03 UTC
Could you tell me status of problem ?

Comment 7 Andrew Clausen 2004-12-21 00:59:52 UTC
L3support: there is no problem.

The filesystem-type parameter to mkpart is mostly irrelevant.  It is
the same as fdisk's partition code option.

Parted mostly ignores it, as does Linux.  This feature is only
provided to keep some people happy.  I can't think of any scenarios on
Linux where it is useful.  (If you are installing a non-Linux
operating system, and need Parted's help, then it can become useful)

This is not a bug, and can be closed.


Note You need to log in before you can comment on or make changes to this bug.