Bug 138333 - HP Color LaserJet 8500 series cannot print
HP Color LaserJet 8500 series cannot print
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
3
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Tim Waugh
:
: 138334 138335 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-08 07:43 EST by Nico Kadel-Garcia
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-09 09:56:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nico Kadel-Garcia 2004-11-08 07:43:49 EST
Description: On Fedora Core 3 Test 3 and its cups-1.1.21-4, I'm 
unable to successfully print *anything* to HP Color LaserJet 8500 
printers with the now available HP Color LaserJet 8500 printer 
drivers.

How reproducible: 
1: Install FC2test3
2: Set up a network printer of HP Color LaserJet 8500 series with 
matching drivers.
3: Try to print a test job to it. (Pick letter-size test jobs, since 
CUPS still defaults to A3.)

Actual results: Various error messages occur, I'll detail those if I 
can find time, but other network printers work fine, so it's not the 
networking layer. And FC1 and FC2 can print to it fine, but only have 
the 8550GN print driver available, so it may be the new 8500 driver.

Expected results: A successful print job of any kind. 

Additional info: I used to be able to print to these with Fedora Core 
2 with HP Color LaserJEt 8550GN drivers, but I don't believe that 
CUPS on that FC2 had a specific 8500 driver.
Comment 1 Tim Waugh 2004-11-08 08:11:09 EST
*** Bug 138334 has been marked as a duplicate of this bug. ***
Comment 2 Tim Waugh 2004-11-08 08:11:32 EST
*** Bug 138335 has been marked as a duplicate of this bug. ***
Comment 3 Tim Waugh 2004-11-08 08:12:53 EST
Please specify the method you are using the set up this printer and
assign a driver to it.  Are you using the CUPS interface directly, or
using the Fedora system-config-printer tool to set up the queue?
Comment 4 Nico Kadel-Garcia 2004-11-08 08:36:14 EST
I'm using the system-config-printer tool on a brand-new installed 
machine and on various other machines. Ye ghods, I hate that cups 
interface: it simply doesn't include basic utilities like setting 
default printers or controlling the "sharing" of printers gracefully.

I've also tried grabbing the configuration from a known working FC2 
system using:
    ssh working-machine "/usr/sbin/printconf-tui --Xexport" 
| /usr/sbin/printconf-tui --Ximport

This got me a working setup for non-color printers, but it doesn't 
work either for the HP Color LaserJet 8500 series printers that I 
really need to support. It's a real deployment killer bug in my 
environment.
Comment 5 Nico Kadel-Garcia 2004-11-08 08:41:27 EST
Oh, and if you think I'm kidding about that CUPS interface, check out 
Eric Raymond's extensive article on these issues at 
http://www.catb.org/~esr/writings/cups-horror.html.

I do appreciate your overall very good work with the system-config-
printer tools, and your discarding of the weird LPD/CUPS parallel 
implementations.
Comment 6 Tim Waugh 2004-11-15 11:19:17 EST
Please can you confirm that you are using the "HP C LaserJet 8550"
model selection, with "omni-compiled" as the driver?

> Actual results: Various error messages occur

Please detail those so that I can diagnose.  Thanks.
Comment 7 Nico Kadel-Garcia 2004-11-15 22:21:11 EST
I can confirm the "HP C LaserJet 8550" driver, omni-compiled, as the 
driver. Unfortunately for my testing purposes, I'm operating from 
home right now and the furshlugginer GTK based system-config-* tools 
don't seem to operaate well over remote X or VNC sessions, with 
inability to select display the options of certain toolbars in normal 
X sessions and inability to activate the "Close" buttons over VNC 
sessions. I'll submit those bugs separately, and provide the exact 
error message tomorrow.

As a workaround, I can get by by using the HP Color LaserJet 8550GN 
driver, which also has the options in its configuration for double-
sided printing which the plain HP C LaserJet 8550 driver options lack.
Comment 8 Tim Waugh 2005-09-09 09:56:47 EDT
This is the default driver now.

Note You need to log in before you can comment on or make changes to this bug.