Bug 138336 - bogomips differs vastly on the two CPU:s in a dual opteron
bogomips differs vastly on the two CPU:s in a dual opteron
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Paradis
Brian Brock
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-08 08:01 EST by David Juran
Modified: 2013-08-05 21:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:14:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Output of dmidecode (13.58 KB, text/plain)
2004-11-12 15:51 EST, David Juran
no flags Details

  None (edit)
Description David Juran 2004-11-08 08:01:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20040924

Description of problem:
We have a dual opteron where /proc/cpuinfo reports vastly different
values for the two CPU:s.

catoosa 26: cat /proc/cpuinfo 
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 5
model name      : AMD Opteron(tm) Processor 244
physical id     : 0
siblings        : 1
stepping        : 1
cpu MHz         : 1792.439
cache size      : 1024 KB
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge
mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext lm
3dnowext 3dnow
bogomips        : 3578.26
TLB size        : 1088 4K pages
clflush size    : 64
address sizes   : 40 bits physical, 48 bits virtual
power management: ts ttp

processor       : 1
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 5
model name      : AMD Opteron(tm) Processor 244
physical id     : 0
siblings        : 1
stepping        : 1
cpu MHz         : 1792.439
cache size      : 1024 KB
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge
mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext lm
3dnowext 3dnow
bogomips        : 4194.30
TLB size        : 1088 4K pages
clflush size    : 64
address sizes   : 40 bits physical, 48 bits virtual
power management: ts ttp


Version-Release number of selected component (if applicable):
kernel-smp-2.4.21-20.EL

How reproducible:
Didn't try

Steps to Reproduce:
1. Seems like the bogomips drift apart after a while. I believe they
are identical right after reboot, however I did not want to reboot the
computer right away in case you would need any more information from
the running kernel.

    

Additional info:
Comment 1 Jim Paradis 2004-11-12 12:58:25 EST
Can you tell me exactly what model of system you have?
Comment 2 David Juran 2004-11-12 15:51:43 EST
Created attachment 106604 [details]
Output of dmidecode
Comment 3 Jim Paradis 2004-11-23 19:57:14 EST
Hmmm... on closer inspection, bogomips shouldn't change unless
cpuinfo[].loops_per_jiffy changes, and *that* is typically set at system startup
and should only change if the cpufreq driver messes with CPU frequencies.  Since
the cpufreq driver isn't even enabled for RHEL3 x86_64 at this time, I'm puzzled...
Comment 4 David Juran 2004-11-30 05:49:35 EST
OK, since I only have my memory to depend upon when I state that the
bogomips values changed while the computer was running, maybe its just
isn't so...
However I just rebooted it, and now it came up with the values 6710.88
and 3578.26 for the two CPU:s, so there certainly still is a problem.
Comment 5 David Juran 2004-12-02 12:18:42 EST
Seems to work now with kernel-smp-2.4.21-20.0.1.EL
Comment 6 Ernie Petrides 2004-12-03 17:38:50 EST
Hi, David.  I'm reopening this bug because nothing changed in the -20.0.1.EL
security errata that could possibly affect the problem.  Jim is busy at the
moment with different bugs, but he'll get back to this someday.  The RHEL3
U4 kernel (-27.EL) is scheduled for release in a couple of weeks (on 12/15).
Comment 7 David Juran 2004-12-07 04:56:02 EST
Seems you're right, I probably just got lucky. Now I can't reproduce
the error with either kernel.
Comment 8 Ernie Petrides 2004-12-07 16:47:29 EST
Thanks for the update, David.  For now, since we've never been able
to reproduce this problem and now you can't either, I'm going to
tentatively close this bug.  If the problem reappears, please reopen.

Thanks.  -ernie
Comment 9 David Juran 2005-01-31 05:06:26 EST
Happened again. This time on a SUN V20z with dual Opteron 250 CPUs and
kernel-smp-2.4.21-27.0.2.EL. Is there any other information I should
extract before I try to reboot the machine? 
Comment 10 David Juran 2005-03-03 10:26:57 EST
Just discovered that for the moment 23 of our 35 dual opteron servers
have a slight differens in the bogomips value reported for the two cpu:s
To be precise, on all of them, the second CPU reports 13.11 bogomips
more then the first one.
Comment 11 Jim Paradis 2005-03-03 16:50:46 EST
Small deviations like this are considered acceptable.  I've noticed
that on 4P systems the bogomips for CPU 0 is sometimes slightly
different than that for CPUs 1, 2, & 3.  This is because CPU 0 is
initialized through a different code path than the others.  Since
"bogomips" begins with "bogo-", we don't consider this a major issue
since it's not intended for high-precision timing calculations or
anything like that.

Please let us know if you see any runtime drift between the values.
Comment 12 Jim Paradis 2005-08-17 17:35:41 EDT
Putting this in NEEDINFO state pending customer update
Comment 13 David Juran 2005-08-23 05:44:07 EDT
right now, we see a 81.92 bogomips deviation on all our machines. Anyway, since
we've stoped using Platform LSF, we no longer have any applicatoin that depends
on this figure, so I'll close this issue.
Comment 15 Issue Tracker 2007-06-26 13:18:12 EDT
Here's another one:

[root@bragi233 root]# cat /proc/cpuinfo | egrep "^(processor|model
name|cpu MHz|bogomips)"
processor       : 0
model name      : Dual Core AMD Opteron(tm) Processor 865
cpu MHz         : 1792.738
bogomips        : 3578.26
processor       : 1
model name      : Dual Core AMD Opteron(tm) Processor 865
cpu MHz         : 1792.738
bogomips        : 3578.26
processor       : 2
model name      : Dual Core AMD Opteron(tm) Processor 865
cpu MHz         : 1792.738
bogomips        : 3578.26
processor       : 3
model name      : Dual Core AMD Opteron(tm) Processor 865
cpu MHz         : 1792.738
bogomips        : 6710.88

I'll attach a sysreport for this system as well.


This event sent from IssueTracker by streeter 
 issue 124968
Comment 16 Issue Tracker 2007-06-26 13:18:15 EDT
And here's another from a single-core system:

[root@modi015 root]# cat /proc/cpuinfo | egrep "^(processor|model
name|cpu MHz|bogomips)"
processor       : 0
model name      : AMD Opteron(tm) Processor 252
cpu MHz         : 2592.634
bogomips        : 5164.23
processor       : 1
model name      : AMD Opteron(tm) Processor 252
cpu MHz         : 2592.634
bogomips        : 5872.02



This event sent from IssueTracker by streeter 
 issue 124968
Comment 17 Issue Tracker 2007-06-26 13:18:19 EDT
[root@ls21-7971-1 ~]# uptime
 13:43:32 up 3 days, 7 min,  1 user,  load average: 0.00, 0.00, 0.00
[root@ls21-7971-1 ~]# cat /proc/cpuinfo
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 65
model name      : Dual-Core AMD Opteron(tm) Processor 2210 HE
stepping        : 2
cpu MHz         : 1800.121
cache size      : 1024 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 2
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca
cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt
rdtscp lm 3dnowext 3dnow pni cx16 lahf_lm cmp_legacy svm cr8_legacy
bogomips        : 3601.60
TLB size        : 1024 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc

processor       : 1
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 65
model name      : Dual-Core AMD Opteron(tm) Processor 2210 HE
stepping        : 2
cpu MHz         : 1800.121
cache size      : 1024 KB
physical id     : 1
siblings        : 2
core id         : 0
cpu cores       : 2
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca
cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt
rdtscp lm 3dnowext 3dnow pni cx16 lahf_lm cmp_legacy svm cr8_legacy
bogomips        : 3599.66
TLB size        : 1024 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc

processor       : 2
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 65
model name      : Dual-Core AMD Opteron(tm) Processor 2210 HE
stepping        : 2
cpu MHz         : 1800.121
cache size      : 1024 KB
physical id     : 0
siblings        : 2
core id         : 1
cpu cores       : 2
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca
cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt
rdtscp lm 3dnowext 3dnow pni cx16 lahf_lm cmp_legacy svm cr8_legacy
bogomips        : 3599.59
TLB size        : 1024 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc

processor       : 3
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 65
model name      : Dual-Core AMD Opteron(tm) Processor 2210 HE
stepping        : 2
cpu MHz         : 1800.121
cache size      : 1024 KB
physical id     : 1
siblings        : 2
core id         : 1
cpu cores       : 2
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca
cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt
rdtscp lm 3dnowext 3dnow pni cx16 lahf_lm cmp_legacy svm cr8_legacy
bogomips        : 3599.62
TLB size        : 1024 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc
[root@ls21-7971-1 ~]# uname -a
Linux ls21-7971-1.gsslab.rdu.redhat.com 2.6.18-8.1.6.el5 #1 SMP Fri Jun 1
18:52:13 EDT 2007 x86_64 x86_64 x86_64 GNU/Linux
[root@ls21-7971-1 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 5 (Tikanga)




[root@bl25pg2-1 ~]# uname -a
Linux bl25pg2-1.gsslab.rdu.redhat.com 2.6.9-42.ELsmp #1 SMP Wed Jul 12
23:32:02 EDT 2006 x86_64 x86_64 x86_64 GNU/Linux
[root@bl25pg2-1 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux AS release 4 (Nahant Update 5)
[root@bl25pg2-1 ~]# uptime
 23:43:56 up 21 days,  6:01,  1 user,  load average: 0.00, 0.00, 0.00
[root@bl25pg2-1 ~]# cat /proc/cpuinfo
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 65
model name      : Dual-Core AMD Opteron(tm) Processor 2218
stepping        : 2
cpu MHz         : 1000.156
cache size      : 1024 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 2
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca
cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext lm 3dnowext
3dnow pni cx16
bogomips        : 4000.15
TLB size        : 1088 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp [4] [5]

processor       : 1
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 65
model name      : Dual-Core AMD Opteron(tm) Processor 2218
stepping        : 2
cpu MHz         : 1000.156
cache size      : 1024 KB
physical id     : 1
siblings        : 2
core id         : 0
cpu cores       : 2
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca
cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext lm 3dnowext
3dnow pni cx16
bogomips        : 4000.15
TLB size        : 1088 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp [4] [5]

processor       : 2
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 65
model name      : Dual-Core AMD Opteron(tm) Processor 2218
stepping        : 2
cpu MHz         : 1000.156
cache size      : 1024 KB
physical id     : 0
siblings        : 2
core id         : 1
cpu cores       : 2
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca
cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext lm 3dnowext
3dnow pni cx16
bogomips        : 2000.07
TLB size        : 1088 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp [4] [5]

processor       : 3
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 65
model name      : Dual-Core AMD Opteron(tm) Processor 2218
stepping        : 2
cpu MHz         : 1000.156
cache size      : 1024 KB
physical id     : 1
siblings        : 2
core id         : 1
cpu cores       : 2
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca
cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext lm 3dnowext
3dnow pni cx16
bogomips        : 2000.07
TLB size        : 1088 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp [4] [5]
[root@bl25pg2-1 ~]# grep bogo /proc/cpuinfo 
bogomips        : 4000.15
bogomips        : 4000.15
bogomips        : 2000.07
bogomips        : 2000.07


WTF!  two of them have half the bogomips???

[root@x3655-1 ~]# uname -a
Linux x3655-1.gsslab.rdu.redhat.com 2.6.20-1.2954.fc6 #1 SMP Fri May 25
16:40:56 EDT 2007 i686 athlon i386 GNU/Linux
[root@x3655-1 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 5 (Tikanga)
[root@x3655-1 ~]# uptime
 17:43:56 up  6:14,  1 user,  load average: 0.07, 0.03, 0.00
[root@x3655-1 ~]# cat /proc/cpuinfo
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 65
model name      : Dual-Core AMD Opteron(tm) Processor 2218
stepping        : 2
cpu MHz         : 2600.232
cache size      : 1024 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca
cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt lm
3dnowext 3dnow pni cx16 lahf_lm cmp_legacy svm cr8legacy ts fid vid ttp tm
stc
bogomips        : 5202.91
clflush size    : 64

processor       : 1
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 65
model name      : Dual-Core AMD Opteron(tm) Processor 2218
stepping        : 2
cpu MHz         : 2600.232
cache size      : 1024 KB
physical id     : 0
siblings        : 2
core id         : 1
cpu cores       : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca
cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt lm
3dnowext 3dnow pni cx16 lahf_lm cmp_legacy svm cr8legacy ts fid vid ttp tm
stc
bogomips        : 5200.15
clflush size    : 64

processor       : 2
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 65
model name      : Dual-Core AMD Opteron(tm) Processor 2218
stepping        : 2
cpu MHz         : 2600.232
cache size      : 1024 KB
physical id     : 1
siblings        : 2
core id         : 0
cpu cores       : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca
cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt lm
3dnowext 3dnow pni cx16 lahf_lm cmp_legacy svm cr8legacy ts fid vid ttp tm
stc
bogomips        : 5200.17
clflush size    : 64

processor       : 3
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 65
model name      : Dual-Core AMD Opteron(tm) Processor 2218
stepping        : 2
cpu MHz         : 2600.232
cache size      : 1024 KB
physical id     : 1
siblings        : 2
core id         : 1
cpu cores       : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca
cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt lm
3dnowext 3dnow pni cx16 lahf_lm cmp_legacy svm cr8legacy ts fid vid ttp tm
stc
bogomips        : 5200.11
clflush size    : 64

[root@x3655-1 ~]# grep bogo /proc/cpuinfo 
bogomips        : 5202.91
bogomips        : 5200.15
bogomips        : 5200.17
bogomips        : 5200.11


[root@x4200m2 ~]# uname -a
Linux x4200m2.gsslab.rdu.redhat.com 2.6.9-55.EL.gtest.19smp #1 SMP Tue May
1 17:13:50 EDT 2007 x86_64 x86_64 x86_64 GNU/Linux
[root@x4200m2 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux AS release 4 (Nahant Update 5)
[root@x4200m2 ~]# uptime
 07:37:17 up 13 days,  7:53,  1 user,  load average: 0.49, 0.78, 0.70
[root@x4200m2 ~]# cat /proc/cpuinfo 
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 65
model name      : Dual-Core AMD Opteron(tm) Processor 2220 SE
stepping        : 2
cpu MHz         : 997.420
cache size      : 1024 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 2
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca
cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext lm 3dnowext
3dnow pni cx16
bogomips        : 1994.72
TLB size        : 1088 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp [4] [5]

processor       : 1
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 65
model name      : Dual-Core AMD Opteron(tm) Processor 2220 SE
stepping        : 2
cpu MHz         : 997.420
cache size      : 1024 KB
physical id     : 0
siblings        : 2
core id         : 1
cpu cores       : 2
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca
cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext lm 3dnowext
3dnow pni cx16
bogomips        : 1994.72
TLB size        : 1088 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp [4] [5]

processor       : 2
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 65
model name      : Dual-Core AMD Opteron(tm) Processor 2220 SE
stepping        : 2
cpu MHz         : 997.420
cache size      : 1024 KB
physical id     : 1
siblings        : 2
core id         : 0
cpu cores       : 2
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca
cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext lm 3dnowext
3dnow pni cx16
bogomips        : 1994.72
TLB size        : 1088 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp [4] [5]

processor       : 3
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 65
model name      : Dual-Core AMD Opteron(tm) Processor 2220 SE
stepping        : 2
cpu MHz         : 997.420
cache size      : 1024 KB
physical id     : 1
siblings        : 2
core id         : 1
cpu cores       : 2
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca
cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext lm 3dnowext
3dnow pni cx16
bogomips        : 1994.72
TLB size        : 1088 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp [4] [5]

[root@x4200m2 ~]# grep bogo /proc/cpuinfo
bogomips        : 1994.72
bogomips        : 1994.72
bogomips        : 1994.72
bogomips        : 1994.72








[root@x4200 ~]# uname -a
Linux x4200.gsslab.rdu.redhat.com 2.6.9-42.7.ELsmp #1 SMP Tue Sep 5
18:29:39 EDT 2006 i686 athlon i386 GNU/Linux
[root@x4200 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux AS release 4 (Nahant Update 4)
[root@x4200 ~]# uptime
 13:36:36 up 38 days,  2:40,  2 users,  load average: 1.12, 0.59, 0.25
[root@x4200 ~]# cat /proc/cpuinfo 
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 33
model name      : Dual Core AMD Opteron(tm) Processor 280 SE
stepping        : 2
cpu MHz         : 2394.454
cache size      : 1024 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca
cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext lm 3dnowext
3dnow pni
bogomips        : 4790.77

processor       : 1
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 33
model name      : Dual Core AMD Opteron(tm) Processor 280 SE
stepping        : 2
cpu MHz         : 2394.454
cache size      : 1024 KB
physical id     : 0
siblings        : 2
core id         : 1
cpu cores       : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca
cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext lm 3dnowext
3dnow pni
bogomips        : 4785.68

processor       : 2
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 33
model name      : Dual Core AMD Opteron(tm) Processor 280 SE
stepping        : 2
cpu MHz         : 2394.454
cache size      : 1024 KB
physical id     : 1
siblings        : 2
core id         : 0
cpu cores       : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca
cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext lm 3dnowext
3dnow pni
bogomips        : 4785.68

processor       : 3
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 33
model name      : Dual Core AMD Opteron(tm) Processor 280 SE
stepping        : 2
cpu MHz         : 2394.454
cache size      : 1024 KB
physical id     : 1
siblings        : 2
core id         : 1
cpu cores       : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca
cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext lm 3dnowext
3dnow pni
bogomips        : 4785.70

[root@x4200 ~]# grep bogo /proc/cpuinfo
bogomips        : 4790.77
bogomips        : 4785.68
bogomips        : 4785.68
bogomips        : 4785.70





This event sent from IssueTracker by streeter 
 issue 124968
Comment 18 Issue Tracker 2007-06-26 13:18:23 EDT
Hi SEG,

This appears to be BZ 138336.  I'm bumping this to internal priority
"2" to match the customer's elevated severity.

Some notes and questions from the customer (this ticket is quickly getting
really, really long and hard to read):

==========
Looks like the same issue in that BZ...

The reason this is a problem for us is that Platform LSF uses the largest
bogomips value to determine CPU speed, and if we can't count on the
bogomips value to be a) reasonably predictable for a given CPU frequency,
and b) the same for all CPUs in a system, then the LSF software reports
incorrect values for the CPU speed, causing our customers' jobs to land
on the wrong systems.

I'm elevating this issue to "high" since it's obviously not an
isolated case, is affecting our customers' jobs, and has been reported by
other people but not gotten enough attention.

We don't have enough 3U9 systems installed yet to have any idea whether
it fixes this problem.  It will be several months before U9 has enough
penetration in our environment.

This problem appears to affect roughly 44% of our systems, i.e. at least
one bogomips entry differs from the others.  Should we expect for a system
with 2-8 identical CPUs to have identical bogomips entries for all cores? 
Or should we expect some small degree of variance?
=========


Issue escalated to Support Engineering Group by: pvn.
Internal Status set to 'Waiting on SEG'
Priority set to: 2

This event sent from IssueTracker by streeter 
 issue 124968
Comment 19 RHEL Product and Program Management 2007-10-19 15:14:40 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.