Bug 138376 - typo in rss generating code of cli.py
typo in rss generating code of cli.py
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
noarch Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
:
: 142129 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-08 12:44 EST by Sertaç Ö. Yıldız
Modified: 2014-01-21 17:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-30 01:09:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sertaç Ö. Yıldız 2004-11-08 12:44:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
yum generate-rss gives traceback

Version-Release number of selected component (if applicable):
yum-2.1.11-3.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1. yum generate-rss
2.
    

Actual Results:  Traceback (most recent call last):
  File "/usr/bin/yum", line 8, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 51, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 245, in getOptionsConfig
    self.parseCommands() # before we exit check over the base command
+ args
  File "/usr/share/yum-cli/cli.py", line 340, in parseCommands
    self.extcmds[0] = 'recent'


Expected Results:  no traceback

Additional info:

possible solution may be changing 
self.extcmds[0] = 'recent'
to
self.extcmds.append('recent')
Comment 1 Seth Vidal 2004-11-09 03:39:38 EST
fixed in cvs, thanks.
Comment 2 Seth Vidal 2004-12-07 11:06:53 EST
*** Bug 142129 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.