Bug 138386 - 2.1U6 beta install: network unusable/unconfigurable
Summary: 2.1U6 beta install: network unusable/unconfigurable
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 2.1
Hardware: ia32e
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-08 19:40 UTC by Wendy Hung
Modified: 2007-11-30 22:06 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-27 16:33:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
this patches the pcitable so RHAS2.1 can recognize the broadcom 5721 card (801 bytes, patch)
2004-11-18 23:27 UTC, Vernon Mauery
no flags Details | Diff

Description Wendy Hung 2004-11-08 19:40:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3)
Gecko/20040910

Description of problem:
The Broadcom 5721 chipset on the x346 does not function during the
install of 2.1U beta.  This essentially prevents customers from doing
network installs via kickstart. CD and hard drive based installs both
work.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Attempt to perform network install on x346 using 2.1 U6 beta 
    Or attempt to configure network during CD install.

    

Actual Results:  Per Mike Gahagan, 
totally non-functional during the install. I didn't have any success
with the expert or noprobe options.

Nic works fine post-install with tg3 and it looks like the
needed pci id entries are present.




Expected Results:  Network install works.
Network can be configured during install.

Additional info:

Comment 1 Bill Nottingham 2004-11-08 19:54:44 UTC
What errors do you get?


Comment 3 Wendy Hung 2004-11-15 21:13:39 UTC
There are no error messages.  During the CD-based install,the network 
configuration screen does not appear.  The configuration is performed 
post-install.  It was expected that the screen would appear during 
the install. 

Comment 4 Wendy Hung 2004-11-17 18:52:49 UTC
raising the severity level to high.  no fix would result in no network
installs using the 5721 chipset which will impact sales. 

Comment 6 Bob Johnson 2004-11-17 19:52:32 UTC
We could use some IBM help here.
This looks like installer does not see 5721, but this is more
complicated than that.

Comment 8 AJ Johnson 2004-11-18 18:32:12 UTC
Since we don't have an x346, I want to give this a shot on the x236 as
it has the same Broadcom chipset.

Comment 9 Vernon Mauery 2004-11-18 20:56:12 UTC
The x236 has the same problem.

Comment 10 Vernon Mauery 2004-11-18 21:18:08 UTC
The x336 also has this problem

Comment 11 Vernon Mauery 2004-11-18 23:27:28 UTC
Created attachment 107008 [details]
this patches the pcitable so RHAS2.1 can recognize the broadcom 5721 card

Comment 12 Vernon Mauery 2004-11-18 23:30:14 UTC
attachment 107008 [details] is a patch against the initrd filesystem used for
the net install.  I unzipped the filesystem, modified
modules/pcitable, gzipped it and placed it back where the tftp server
could hand it out.  It worked fine for me on the x236.

Comment 13 Bob Johnson 2004-11-19 03:41:53 UTC
Vernon, thanks, I think this is where Jeremy is working this issue also.

Comment 14 Wendy Hung 2004-11-19 21:32:49 UTC
Results from testing Vernon's patch on a x346 will be available 
11/22.  The expectation is that it should work just as the x236 did.  
Is there a new cut of 2.1u6?  if so, we can test that too. 

Comment 15 Wendy Hung 2004-11-22 20:52:47 UTC
Patch has been tested successfully on the x236, x336 and the x346. 

Comment 16 Wendy Hung 2005-01-27 16:33:42 UTC
The patch was included in U6.


Note You need to log in before you can comment on or make changes to this bug.