Bug 138388 - clumanager upgrade postuninstall script fails if /etc/cluster.xml doesn't exist
Summary: clumanager upgrade postuninstall script fails if /etc/cluster.xml doesn't exist
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: clumanager   
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-08 20:06 UTC by Derek Anderson
Modified: 2009-04-16 20:15 UTC (History)
3 users (show)

Fixed In Version: clumanager-1.2.25-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-28 17:42:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:047 high SHIPPED_LIVE clumanager and redhat-config-cluster bug fix update 2005-05-25 04:00:00 UTC

Description Derek Anderson 2004-11-08 20:06:20 UTC
Description of problem:
Was just running install/upgrade/downgrade tests on the clumanager
package with the produce configured.  In this case, on upgrade and
downgrades you get the following error message:

[root@bench-01 root]# rpm -Uvh clumanager-1.2.22-2.i386.rpm
Preparing...               
########################################### [100%]
   1:clumanager            
########################################### [100%]
error: %postun(clumanager-1.2.16-1) scriptlet failed, exit status 1

It still upgrades, but you get the error.

More detail with debugging turned up:
D:     erase: %postun(clumanager-1.2.16-1) asynchronous scriptlet start
D:     erase: %postun(clumanager-1.2.16-1)      execv(/bin/sh) pid 8748
+ ldconfig
+ '[' 1 -ge 1 ']'
+ /sbin/service clumanager condrestart
D:     erase: waitpid(8748) rc 8748 status 100 secs 0.063
error: %postun(clumanager-1.2.16-1) scriptlet failed, exit status 1


Version-Release number of selected component (if applicable):
clumanager-1.2.22-2

How reproducible:


Steps to Reproduce:
1. Remove /etc/cluster.xml
2. Upgrade the package with rpm
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Lon Hohberger 2005-01-03 16:09:08 UTC
I've fixed this in the development pool; it will be in the next erratum.

It occurs because it /etc/init.d/clumanager checks to see if
/etc/cluster.xml exits and exits with 1 instead of zero if it doesn't
exist.

It should exit with 0.


Comment 3 Derek Anderson 2005-02-28 17:42:13 UTC
Verified with clumanager-1.2.25-2.  Should probably be checking
existence of $CFG_FILE since you defined it earlier.  :)

Comment 4 Lon Hohberger 2007-12-21 15:10:37 UTC
Fixing product name.  Clumanager on RHEL3 was part of RHCS3, not RHEL3


Note You need to log in before you can comment on or make changes to this bug.