Bug 138410 - up2date openoffice.org fails at test install due to package conflicts
up2date openoffice.org fails at test install due to package conflicts
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-08 18:57 EST by David G Sparks
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-09 21:50:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
session log of the problem (9.72 KB, text/plain)
2004-11-08 18:59 EST, David G Sparks
no flags Details

  None (edit)
Description David G Sparks 2004-11-08 18:57:52 EST
Description of problem: up2date openoffice.org fails at the test
install step. Many lines fill the console reporting package conflicts.
Full session is attached for reference.


Version-Release number of selected component (if applicable):currently
installed Oo 1.1.1-4 attempting to update to Oo 1.1.2-10.fc2


How reproducible: Recently installed the latest .iso's onto a i686
system. Have been updating alphabetically from a-z, ran into this
problem on the third or fourth day when I got to the o's. up2date has
been working fine until this. It continues to work fine on packages
with names starting with p and beyond. Only openoffice.org is giving
this problem.


Steps to Reproduce: see attached session log
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 David G Sparks 2004-11-08 18:59:17 EST
Created attachment 106302 [details]
session log of the problem

Here is the session log with all steps and the error messages.
Comment 2 Dan Williams 2004-11-08 22:13:19 EST

*** This bug has been marked as a duplicate of 136754 ***
Comment 3 David G Sparks 2004-11-08 22:45:40 EST
Hey, Dan. Sorry, but bug 136754 is about problems on 86-64 machines.
Mine is an i386-only problem. Also I tried what was described in bug
136754 but it did not work. So I am requesting another look at this one.

Thanks,  David

Here's what was suggested to place into /etc/yum.conf

# cat /etc/yum.conf
[main]
cachedir=/var/cache/yum
debuglevel=2
logfile=/var/log/yum.log
pkgpolicy=newest
distroverpkg=redhat-release
tolerant=1
exactarch=1
retries=20
 
[base]
name=Fedora Core $releasever - $basearch - Base
baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/$releasever/$basearch/
 
[updates]
name=Fedora Core $releasever - $basearch - Updates
baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/updates/$releasever/$basearch/
 
Here's what happened:

# yum update openoffice.org
Gathering header information file(s) from server(s)
Server: Fedora Core 2 - i386 - Base
retrygrab() failed for:
 
http://download.fedora.redhat.com/pub/fedora/linux/core/2/i386/headers/header.info
  Executing failover method
failover: out of servers to try
Error getting file
http://download.fedora.redhat.com/pub/fedora/linux/core/2/i386/headers/header.info
[Errno 4] IOError: HTTP Error 404: Not Found


What do we try next?
Comment 4 David G Sparks 2004-11-09 21:50:17 EST
Restored yum.conf to as-installed version, not special version show
previously, and was able to update openoffice.org manually in two
sessions: 
yum update openoffice.org
yum update openoffice.org-i18n

Lesson learned: if up2date chokes,  try yum update 

Peace,

David

Note You need to log in before you can comment on or make changes to this bug.