Bug 138450 - new kdemultimedia makes ldconfig spit error messages
Summary: new kdemultimedia makes ldconfig spit error messages
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: prelink   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-09 12:37 UTC by Nils Philippsen
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-23 09:38:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nils Philippsen 2004-11-09 12:37:53 UTC
Description of problem:

SSIA:

root@gibraltar:~> rpm -Uvh
/var/cache/yum/updates-released/packages/kdemultimedia-3.3.1-1.i386.rpm
Preparing...               
########################################### [100%]
   1:kdemultimedia         
########################################### [100%]
/sbin/ldconfig: /usr/lib/libkdeinit_kmixctrl.so is not a symbolic link

/sbin/ldconfig: /usr/lib/libkdeinit_kmix.so is not a symbolic link

root@gibraltar:~> rpm -qf /usr/lib/libkdeinit_kmixctrl.so
/usr/lib/libkdeinit_kmix.so
kdemultimedia-3.3.1-1
kdemultimedia-3.3.1-1


Version-Release number of selected component (if applicable):
kdemultimedia-3.3.1-1

How reproducible:
Always

Steps to Reproduce:
1. Have kdemultimedia-3.3.1-1 installed
2. run ldconfig
  
Actual results:
See above.

Expected results:
No error messages

Comment 1 Ngo Than 2004-11-24 10:29:46 UTC
it's strange, i cannot reproduce this on my machine!

Jakub, does ldconfig expect that libfoo.so is always a symlink?

Comment 2 Jakub Jelinek 2004-11-24 11:37:18 UTC
This message is only printed if library and `dirname library`/`readelf -d library | grep SONAME | sed 's,^.*\[,,;s,\]$,,'`
both exist, are different and library is not a symbolic link.


Comment 3 Nils Philippsen 2004-11-25 11:57:16 UTC
Hmm, seems that it complained about left-over temporary files from prelink
(libkdeinit_kmix.so.#prelink#.QGSCdD libkdeinit_kmixctrl.so.#prelink#.ltF77N), I
think that this measn that I shut down the machine when prelink was running. Is
this a bug or expected?

Comment 4 Jakub Jelinek 2006-05-23 09:38:40 UTC
ldconfig disregards the prelink temporaries these days.


Note You need to log in before you can comment on or make changes to this bug.