Bug 138451 - up2date --help gives error
Summary: up2date --help gives error
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Max Spevack
URL:
Whiteboard:
Keywords:
: 137279 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-09 13:05 UTC by Holger Eilhard
Modified: 2007-11-30 22:10 UTC (History)
4 users (show)

Fixed In Version: 4.3.58
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-23 22:13:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Holger Eilhard 2004-11-09 13:05:57 UTC
Description of problem:
#up2date --help
While trying to get the help on up2date I get the following result:
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1248, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 355, in main
    (options, pkgNames) = optparser.parse_args()
  File "/usr/lib/python2.3/optparse.py", line 1129, in parse_args
    stop = self._process_args(largs, rargs, values)
  File "/usr/lib/python2.3/optparse.py", line 1169, in _process_args
    self._process_long_opt(rargs, values)
  File "/usr/lib/python2.3/optparse.py", line 1244, in _process_long_opt
    option.process(opt, value, values, self)
  File "/usr/lib/python2.3/optparse.py", line 611, in process
    return self.take_action(
  File "/usr/lib/python2.3/optparse.py", line 632, in take_action
    parser.print_help()
  File "/usr/sbin/up2date", line 89, in print_help
    OptionParser.print_help(self, file)
  File "/usr/lib/python2.3/optparse.py", line 1370, in print_help
    file.write(self.format_help())
TypeError: descriptor 'write' requires a 'file' object but received a
'str'

same for #up2date -h


Version-Release number of selected component (if applicable):
up2date-4.3.47-5

How reproducible:
always

Steps to Reproduce:
1. run up2date -h

Comment 1 M Kool 2004-11-20 11:43:18 UTC
I also ran into this problem. Looking in usr/bin/up2date on line 89,
it seems to me that there is a typo.

It says:

88 def print_help(self, filed=None):
89    OptionParser.print_help(self, file)
90
91    if not filed:
92        filed = stdout:

I think that the 'file' parameter should be 'filed'. At least on my
system up2date is working again now.



Comment 2 Holger Eilhard 2004-11-20 11:48:05 UTC
Yep, that did the trick.

Comment 3 Max Spevack 2004-11-21 20:45:59 UTC
A friend of mine just emailed me complaining about this.  He was going
to file a bug too, but a quick query found this one.

He's running fc3 with up2date-4.3.47-5 as well.

Comment 4 Adrian Likins 2004-11-22 17:41:16 UTC
fixed in 4.3.65 (actually, I belive somewhere in the .50's) but
thats the latest version and includes the fix.

Comment 5 Need Real Name 2004-12-02 15:30:49 UTC
Dupe of 137279

Comment 6 Max Spevack 2004-12-07 23:00:08 UTC
*** Bug 137279 has been marked as a duplicate of this bug. ***

Comment 7 Max Spevack 2005-01-04 18:12:04 UTC
Fix verified in 4.3.58 from fc3-updates-candidate


Note You need to log in before you can comment on or make changes to this bug.