Bug 138488 - jbd.ko not included in UTF-8 locales
Summary: jbd.ko not included in UTF-8 locales
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: mkinitrd   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-09 16:09 UTC by Charles Lopes
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-09 16:28:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Charles Lopes 2004-11-09 16:09:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
In a UTF-8 locale, mkinitrd fails to detect the dependency ext3 -> jbd
I tracked the problem down to an awk scriptlet in moduledep(). It
seems that the gawk function "match" behaves differently in UTF-8
locales. Setting LC_ALL=C in mkinitrd should fix this problem.

Version-Release number of selected component (if applicable):
4.1.18-2

How reproducible:
Always

Steps to Reproduce:
1. LC_ALL=en_US.UTF-8 mkinitrd -v -f /boot/initrd-2.6.9-1.667.img
2.6.9-1.667
2. LC_ALL=C mkinitrd -v -f /boot/initrd-2.6.9-1.667.img 2.6.9-1.667
3. Compare results

Actual Results:
...
Looking for deps of module raid1
Looking for deps of module ext3
Looking for deps of module dm-mod
Looking for deps of module dm-mirror     dm-mod
...


Expected Results:
...
Looking for deps of module raid1
Looking for deps of module ext3  jbd
Looking for deps of module jbd
Looking for deps of module dm-mod
Looking for deps of module dm-mirror     dm-mod
...

Comment 1 Jeremy Katz 2004-11-09 16:24:54 UTC
What version of gawk do you have installed?

Comment 2 Charles Lopes 2004-11-09 16:28:11 UTC
Silly me! Gawk version 3.1.4, a left over from rawhide. Downgraded
back to 3.1.3. No problem there. I'm closing this. Sorry!



Note You need to log in before you can comment on or make changes to this bug.