Bug 138494 - running "strings" on >2GB files
running "strings" on >2GB files
Status: CLOSED DUPLICATE of bug 133555
Product: Fedora
Classification: Fedora
Component: binutils (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Depends On:
  Show dependency treegraph
Reported: 2004-11-09 11:32 EST by Maciej Żenczykowski
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-11-09 11:33:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Maciej Żenczykowski 2004-11-09 11:32:28 EST
Description of problem:
strings doesn't work on >=2GB file.

Linux zeus 2.6.8-1.521smp #1 SMP Mon Aug 16 09:25:06 EDT 2004 i686
i686 i386 GNU/Linux
ext3 partition

[maze@zeus fc3]$ strings FC3-i386-DVD.iso 
strings: Warning: could not locate 'FC3-i386-DVD.iso'.  reason: Value
too large for defined data type

__xstat(3, "FC3-i386-DVD.iso", 0xfee362b0)       = -1
__errno_location()                               = 0xf6fe1060
strerror(75)                                     = "Value too large
for defined data"...

stat64("FC3-i386-DVD.iso", {st_mode=S_IFREG|0664, st_size=2466410496,
...}) = 0

Version-Release number of selected component (if applicable):

How reproducible:
Comment 1 Jakub Jelinek 2004-11-09 11:33:31 EST

*** This bug has been marked as a duplicate of 133555 ***
Comment 2 Maciej Żenczykowski 2004-11-09 11:36:00 EST
lol, beat me to it - was about to mark it as a dupe, after I read your

Note You need to log in before you can comment on or make changes to this bug.