Bug 138501 - Installer does not create normal user account
Installer does not create normal user account
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: system-config-users (Show other bugs)
3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-09 13:07 EST by Filipe Torres
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-10 02:42:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Filipe Torres 2004-11-09 13:07:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3)
Gecko/20040913 Firefox/0.10

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Install FC3:
Boot prompt arguments: linux reiserfs

Language: Portuguese(Portugal)

Partitions were already there, but were set up manually because of
error in partition autodetection (other bug)
1 /boot partition ext3 (100Mb) formatted
1 / partition reiserfs (20Gb) formatted
1 swap partition (1500Mb) formatted

SELinux fully enabled and active.

Anaconda asks for regular user account details after reboot. Details
are filled in without no error.

Finish install.

GDM starts for first login. Regular user created above can't login.

Login as root. 
Start system-config-users from CLI.
Check that regular user created during install does not exist.

Try to create new user. 
Fill in user details.
Click OK and the new user dialog *hangs*.
Check CLI output for error message.

Completely disable SELinux.
Reboot.
System-config-users works again.


Actual Results:  Installer does not create regular user account.
System-config-users cannot create regular user accounts.

Expected Results:  User should have been created during install, and
system-config-users should create user and associated group.

Additional info:

-----------------------------------------------------------
Output of system-config-users after the new user dialog hangs:
---------------------------------------------------------------
[root@localhost ~]# system-config-users
Traceback (most recent call last):
  File "/usr/share/system-config-users/userWindow.py", line 345, in
on_userWin_ok_button_clicked
    self.parent.ADMIN.addGroup(groupEnt)
RuntimeError: couldn't get security context of `/etc/group': No data
available
-----------------------------------------------------------
Also, disabling SELinux completely solves the problem.
Alternatively, changing SELinux mode to permissive allows me to use
useradd command to create user, but system-config-users still hangs.
-----------------------------------------------------------------
Maybe this is related to using reiserfs/pt-PT language with SELinux?
Comment 1 Daniel Walsh 2004-11-09 19:59:19 EST
reiserfc and SELinux is not supported.  Please send the AVC messages
from the /var/log/messages and I will try to update policy.

Dan
Comment 2 Nils Philippsen 2004-11-10 02:42:29 EST
It looks as if your file system hasn't been labeled which is to be
expected since reiserfs doesn't support extended attributes, i.e. the
error is certainly not s-c-users or anaconda. If you really want, try
to reproduce it on ext3 (though I doubt that the error will persist
there).
Comment 3 Anthony G 2004-11-30 20:39:45 EST
[root@host hostname]# system-config-users
Traceback (most recent call last):
  File "/usr/share/system-config-users/userWindow.py", line 348, in
on_userWin_ok_button_clicked
    self.parent.ADMIN.addGroup(groupEnt)
RuntimeError: couldn't get security context of `/etc/group': No data
available
[root@host hostname]# useradd
bash: useradd: command not found
[root@host hostname]# which useradd
/usr/bin/which: no useradd in
(/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:/home/halcyon/bin)
[root@host hostname]# mount
/dev/hde3 on / type ext3 (rw)
none on /proc type proc (rw)
none on /sys type sysfs (rw)
none on /dev/pts type devpts (rw,gid=5,mode=620)
usbfs on /proc/bus/usb type usbfs (rw)
/dev/hde1 on /boot type ext3 (rw)
none on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
/dev/hdg6 on /mnt/hdg6 type ext3 (rw)
[root@host hostname]#

Disabling SELinux solves the problem hre too.  Still happens with
ext3, although my drives aren't on a managed volume.  Perhaps this is
the problem?
Comment 4 Daniel Walsh 2004-11-30 20:44:55 EST
How was this machine installed?  Are there security contexts on /?

What does 
ls -lZ /etc/shadow

show
Comment 5 Anthony G 2004-12-01 05:33:54 EST
-r--------  root     root                                      /etc/shadow

The machine was installed normally aside from the partitions, which
were done manually.  SELinux was enabled after 2 users were created. 
How do I check security context?
Comment 6 Anthony G 2004-12-04 01:06:38 EST
I downloaded the ISOs as opposed to a network install, also.  The
configuration is a workstation with some additional packages selected
for development and graphics.  Before logging in I ran a failsafe
terminal and did up2date -fu, updated to 2.6.9-1.681_FC3 and rebooted.
 I logged in, created the users, installed the commercial nVidia
drivers, enabled SELinux and rebooted again. 

Note You need to log in before you can comment on or make changes to this bug.