Bug 138524 - eject doesn't eject CD if the drive is a cdrecorder
eject doesn't eject CD if the drive is a cdrecorder
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: eject (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-09 14:17 EST by Przemyslaw Sowa
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-12 07:33:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Przemyslaw Sowa 2004-11-09 14:17:03 EST
Description of problem:
The application doesn't look for cdrecorder as default device so if
you try to eject CD from such drive it doesn't work. It is not
possible to eject CD in Gnome 2.8 and in other software that uses
eject program.

Version-Release number of selected component (if applicable):
eject-2.0.13-10

How reproducible:
Always (I think)

Steps to Reproduce:
1. First you should have cdrecorder mount point /media/cdrecorder in
/etc/fstab (standard entry created by Fedora Core 3 installer).
2. Mount /media/cdrecorder.
3. Then execute "eject"
  
Actual results:
An error is reported: "eject: unable to find or open device for: `cdrom'"

Expected results:
The application should also check for 'cdrecorder' as default device,
not only 'cdrom'.

Additional info:
Maybe it should be an array of default devices not only on 'cdrom'.
Comment 1 Ngo Than 2004-11-12 07:33:50 EST
it looks like the cdrom symlink is missing in /dev. Please update  
udev-039-10.FC3.1 in fc3 updates. It will fix this problem.

Note You need to log in before you can comment on or make changes to this bug.