Bug 138527 - Key import message on initial install not working behavior
Summary: Key import message on initial install not working behavior
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-09 19:26 UTC by Steve Wardell
Modified: 2014-01-21 22:50 UTC (History)
2 users (show)

Fixed In Version: FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-14 17:27:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steve Wardell 2004-11-09 19:26:20 UTC
Description of problem:

After a fresh FC3 install, when running yum update, the message about
keys to import is incorrect.

Version-Release number of selected component (if applicable):

2.1.11-3

How reproducible:

Very

Steps to Reproduce:
1. Fresh minimal FC3 install
2. Login as root and run yum update
  
Actual results:

Yum returns the error:

You have enabled checking of packages via GPG keys. This is a good thing.
However, you do not have any GPG public keys installed. You need to
download
the keys for packages you wish to install and install them.
You can do that by running the command:
    rpm --import public.gpg.key
For more information contact your distribution or package provider.


Expected results:

Yum mentions to install the correct keys as up2date mentions when
running it for the first time.

To install the key, run the following as root:
     rpm --import /usr/share/rhn/RPM-GPG-KEY
     rpm --import /usr/share/rhn/RPM-GPG-KEY-fedora

If you run these imports (which up2date said), then yum update works fine.

Comment 1 Seth Vidal 2004-11-09 19:29:04 UTC
Why is the message incorrect?

Yum runs on multiple distributions, up2date only runs on one.

Having a fedora-specific message in yum would be inappropriate.


Comment 2 Steve Wardell 2004-11-09 19:36:06 UTC
This message is incorrect as it does not achieve the intended behavior
on Fedora. There's 2 possible routes to address:

1) fedora specific message pointing to the correct key(s) when running
yum update
2) A way such that "rpm --import public.gpg.key" installs the
necessary key(s) on Fedora

Either one of these changes would address this issue and the summary
has been adjusted thou in it's current behavior it's a bug.



Comment 3 Toni Willberg 2004-11-13 17:29:18 UTC
That error message should be distribution dependant. That way it could
give useful instructions to user how to install the keys.

Perhaps the error message could be configurable in system-wide
yum-vendor.conf, which would possibly be provided by separate package?
I would split "yum" package to "yum" and "yum-fedora" (or something
similar).


Comment 4 Steve Wardell 2004-11-14 18:12:47 UTC
Why is this being WONTFIX'd? The message displayed to the user is not
one that will work on Fedora. This should not require a large rework.
There are any number of ways to address this issue, be it a way to
have the message changed through system independences or having the
command presented to the user be one that takes the desired action of
importing the necessary keys. Can this issue please be reopened?

Comment 5 Seth Vidal 2004-11-14 18:41:26 UTC
why not file this same bug against rpm, too? Rpm should have
vendor-differential code to tell it which rpm gpg keys to use.

The reason it was wontfix'd is b/c doing what you're describing is a
bit silly. If a distribution vendor wishes to apply a patch to fix
that string they can.



Comment 6 Steve Wardell 2004-11-14 19:05:15 UTC
One of the options I am suggesting is for this vendor (Fedora) to
apply that patch to fix the string. That's what this bug is about.
This bug is not against the core yum product instead but against
Fedora's use of it. So the item is not silly in any sense and does
correct a valid problem of an invalid error / warning message in
Fedora's case (but agreed, it's not a bug against yum but IS a bug
against Fedora). Can this be re-opened? Would a patch to address the
issue in Fedora's implementation be accepted of presented?

Comment 7 Steve Wardell 2005-09-02 21:51:24 UTC
This works well with yum in FC4 now.


Note You need to log in before you can comment on or make changes to this bug.