This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 138530 - Double-click can ignore word boundaries
Double-click can ignore word boundaries
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vte (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-09 14:44 EST by Pete Zaitcev
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-02 15:11:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Good selection (84.63 KB, image/jpeg)
2006-06-06 17:59 EDT, Pete Zaitcev
no flags Details
The bug: bad double-click selection. (85.33 KB, image/jpeg)
2006-06-06 18:01 EDT, Pete Zaitcev
no flags Details

  None (edit)
Description Pete Zaitcev 2004-11-09 14:44:15 EST
Description of problem:

In certain circumstances, double-click selects across word boundary
characters.

Version-Release number of selected component (if applicable):

vte-0.11.11-6

How reproducible:

100% with bash

Steps to Reproduce:
1. Use bash as a shell
2. Type a long command which makes bash to scroll one line when
   cursor-up is hit. Any gibberish will do. Enter it, so history
   has it.
3. Create a directory and populate it with files. Better not have
   directories, just to have less stuff.
4. Type "ls *", Enter. Say, you see:

[zaitcev@lembas uml]$ ls *
foo                       uml-patch-2.4.23-2.bz2
[zaitcev@lembas uml]$ 

   If you cursor-up the "ls *", and re-execute it, everything will
   be all right. Double-click on foo to verify. But wait...
5. Cursor-up to the long command. Bash will scroll one line up to
   fit that.
6. Cursor-down to the "ls *". Enter it. You see normal output,
   exactly the same as at the step 4.
7. NOW, double-click at "foo" in the example above. The vte will
   select the asterisk.

Actual results:

Selection of space at the end of "ls", asterisk, newline, and "foo".

Expected results:

Selection of "foo".

Additional info:

This is a bug in vte. The old gnome-terminal before vte didn't have
it. However, I didn't file before because I did not understand what
it took to reproduce. It should be clear now.

The most amusing result happens if you do type "rm", middle-button,
and hit enter before you realize what you've done. Then, rm says
that the file you wanted to remove does not exist already, ehehe :-)
Comment 1 Sitsofe Wheeler 2004-12-02 05:40:05 EST
Possibly related to bug 107716 ?
Comment 2 Sitsofe Wheeler 2006-06-06 15:13:23 EDT
Pete:

Is this still here in FC5?
Comment 3 Pete Zaitcev 2006-06-06 17:58:29 EDT
Yep, same story on vte-0.12.1-1.fc5.1. Why do you ask, doesn't it reproduce?
Just follow the steps precisely, and it's 100% reproducible on demand.

They key is in a) the long command and b) recalling it with cursor-up.
Doing so is easy to create a situation where you have two exactly identical
outputs on the same screen, where double-click selections behave differently.
I'm attaching a couple of screenshots.
Comment 4 Pete Zaitcev 2006-06-06 17:59:52 EDT
Created attachment 130644 [details]
Good selection

After double-clicking into a filename.
Comment 5 Pete Zaitcev 2006-06-06 18:01:19 EDT
Created attachment 130645 [details]
The bug: bad double-click selection.

Same output from ls, but double-click selects wrap.
Comment 6 Sitsofe Wheeler 2006-06-07 06:25:30 EDT
Pete:

I don't have the power to change the bugzilla version number even when I can
reproduce it so it's easier to ask you to check and bump it up...
Comment 7 Matthias Clasen 2006-08-02 14:02:55 EDT
Doesn't happen for me. Behdad, have there been changes to the selection
behaviour that could have fixed this ?
Comment 8 Pete Zaitcev 2006-08-02 15:11:24 EDT
vte-0.13.4-1 appears to work.
Comment 9 Behdad Esfahbod 2006-08-02 22:53:15 EDT
Doesn't happen here either.  I completely rewrote how selection works.  That's
in 0.13.4.  and I remember some selection problems with bash that are fixed in
the latest version that is shipped in Fedora (that's in FC5 though).  All in
all, I agree that this is FIXED now.

Note You need to log in before you can comment on or make changes to this bug.