Bug 138538 - jukebox-like CD changing back and forth to install multiple packages
jukebox-like CD changing back and forth to install multiple packages
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-packages (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-09 15:12 EST by das_deniz
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-11 14:22:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description das_deniz 2004-11-09 15:12:10 EST
Description of problem:

The same CD must is prompted for multiple times when
installing packages.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install default profile for RHEL 4.0 (AS) - beta 2 from CD
2. Run system-config-packages
3. select development, documentation, system-tools
  
Actual results:

install of additional packages proceeds but asks for CDs:

2, 3, 4, 1, 2, 3, 2, 3, 2, 3, 2, 4, 2, 3, 2, 3 (you get the idea)

Expected results:

ask for the CDs needed from 1-5 ONCE.

Additional info:
Comment 1 Jeremy Katz 2004-11-11 11:33:54 EST
After installation, we have to follow RPM's package ordering which
doesn't take into account what CD is where.
Comment 2 das_deniz 2004-11-11 12:01:44 EST
DON'T BE REDICULOUS COPY THE NEEDED RPMS TO THE UP2DATE (OR SOME SUCH)
DIRECTORY AND INSTALL FROM THERE IN THE FINAL STAGE
Comment 3 Jeremy Katz 2004-11-11 14:22:02 EST
The problem is that the amount of space required may far outweigh the
amount of space available.  system-config-packages intentionally
doesn't do this as you basically require twice as much disk space to
do it that way and we can't at all guarantee that you have that.
Comment 4 das_deniz 2004-11-13 21:47:27 EST
and if you let your system go too long w/o running up2date it could
have the same problem, no? even more because you're copying over rpms
for packages that are already installed - and it has the option of
grabbing the src rpms too!

so, isn't there some code you can reuse that does a space check and
does the simple, non-jukebox copy method if possible? I mean really, a
little effort and you could FIX this exceptionally annoying BUG for
90% of the time.

EOF

Note You need to log in before you can comment on or make changes to this bug.