Bug 138550 - Maxint Limit Reached in iostat
Maxint Limit Reached in iostat
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: sysstat (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-09 16:00 EST by Kevin Stussman
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: sysstat-5.0.5-11.rhel3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-03 08:54:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Stussman 2004-11-09 16:00:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; Linux i686; U) Opera 7.54  [en]

Description of problem:
Notice how the kB_read column never changes? Is this some sort of limit
being reached? Somehow I doubt that reading has stopped on that
partition.

iostat -dk
Device:            tps    kB_read/s    kB_wrtn/s    kB_read    kB_wrtn
------------
/dev/sdc        221.87      1763.42       726.04 1073741823  442086076
/dev/sdc1       221.87      1763.42       726.04 1073741823  442086076
------------
/dev/sdc        221.87      1763.38       726.03 1073741823  442086664
/dev/sdc1       221.87      1763.38       726.03 1073741823  442086664
------------
/dev/sdc        221.87      1763.33       726.01 1073741823  442087740
/dev/sdc1       221.87      1763.33       726.01 1073741823  442087740
------------


kernel : 2.4.21-20.ELsmp
iostat -v produces : sysstat version 4.0.7




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. do a lot of disk transfers
2. run iostat -dk
    

Actual Results:  the kB_read field never changes once the threshold is reached. I bet 
that the other fields have the same limit.

Expected Results:  the real kb transfer number should be shown (or maybe the counter 
should have reset?)

Additional info:
Comment 1 Kevin Stussman 2004-11-11 12:03:30 EST
compiled sysstat-5.0.6 on this machine and it seems to be fixed for
that version. Not sure what version it was fixed in, but it seems that
making an upgrade of systat available would make this problem go away.

sysstat version 5.0.6

Device:            tps    kB_read/s    kB_wrtn/s    kB_read    kB_wrtn
--------------------
sdc             213.18      2092.94       679.92 1728492409  561521144
sdc1            213.18      2092.94       679.92 1728491909  561521144
--------------------
sdc             213.18      2092.93       679.91 1728493077  561521192
sdc1            213.18      2092.93       679.91 1728492577  561521192
--------------------
sdc             213.18      2092.86       679.89 1728493557  561522004
sdc1            213.18      2092.86       679.89 1728493057  561522004
Comment 2 Charlie Bennett 2004-11-18 14:05:50 EST
we've put 5.0.5 in the update due shortly...

Preview my dev version at:

http://people.redhat.com/ccb/sysstat/RHEL3/5.0.5-7.rhel3/
Comment 3 Kevin Stussman 2004-11-18 14:35:39 EST
Thanks for the update. I will check the newly updated sysstat on that
machine when it becomes available in the regular update channels. As
long as 5.0.5 already has this fix (as in 5.0.6), it should be fine.

Note You need to log in before you can comment on or make changes to this bug.