Bug 138560 - Install hang when loading gdth driver.
Summary: Install hang when loading gdth driver.
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 4.0
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Tom Coughlan
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-09 21:42 UTC by Benoit Roy
Modified: 2010-06-07 04:51 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-07 04:51:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log from power-up to GDT init (from Mandrake 10.0) (18.49 KB, text/plain)
2004-11-20 04:30 UTC, Benoit Roy
no flags Details

Description Benoit Roy 2004-11-09 21:42:56 UTC
Description of problem:
  When trying to install RHEL 4 Beta 2 on an Intel server
  (SCB2SCSI, 2 CPU install and SRCMR RAID controller),
  system hang on âLoading gdth driver ...â.

  I only tried with RHEL4-Beta2-i386-AS-disc1.
  Will other versions of RHEL 4 (ES, WS or desktop) change something ?

  Feel free to reassign component if a more suitable one exist
  for this problem (maybe kernel issue ?).


How reproducible:
  Always


Steps to Reproduce:
1. Press <ENTER> to start graphical install.


Actual results:
  System hang.


Additional info:
  Same behaviour on RHEL Beta 1 and Fedora Core 3.

  System works fine with other OS (other Linux distributions or ...)
  so it shouldn't be related to hardware issue.

Comment 1 Tom Coughlan 2004-11-19 13:26:14 UTC
> Will other versions of RHEL 4 (ES, WS or desktop) change something ?

No, they use the same kernel.

> System works fine with other OS (other Linux distributions or ...)

Have you tried other 2.6 Linux kernels?

I suspect the problem may be with the gdth driver in 2.6. It is not
very widely used anymore. A problem was fixed recently with gdth on a
large memory system.  How much memory does your system have?



Comment 4 Benoit Roy 2004-11-19 17:42:50 UTC
Have you tried other 2.6 Linux kernels?

> Yes, I used Mandrake 10.0 Official (kernel: 2.6.3.7).

My system isn't a large memory system (it actually have 2 Gbytes of RAM).

Is there a command I can issue to figure out what driver Mandrake is
using (I'm no to familiar with Linux) ?

Comment 6 Tom Coughlan 2004-11-19 20:34:15 UTC
The driver will print its version number when it is loaded. Have a
look at dmesg after boot, or /var/log/messages. This may not be much
help because I doubt the version number has been incremented lately,
but if you could post that whole section from the log it might be helpful.

Comment 7 Benoit Roy 2004-11-20 04:30:43 UTC
Created attachment 107110 [details]
Log from power-up to GDT init (from Mandrake 10.0)

Comment 9 illtud 2006-04-12 16:41:25 UTC
Is this still open? I'm getting this with U1 install, and I'm currently
downloading the U3 isos, but I think this should either be closed if it's
resolved or somebody should have fixed it if it isn't!

Comment 10 Tom Coughlan 2006-04-12 17:22:09 UTC
I do not have a gdth adapter to test with, so this BZ has languished. Let know
your results. Would you be able to try a patch? The easiest way would be to boot
off some other hardware, then test the gdth. 


Note You need to log in before you can comment on or make changes to this bug.