Bug 138569 - no symlink to cyradm
Summary: no symlink to cyradm
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: cyrus-imapd   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John Dennis
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-09 22:32 UTC by shrek-m
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-12 19:26:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description shrek-m 2004-11-09 22:32:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.7.3)
Gecko/20040914

Description of problem:
ia am missing a symlink for the  cyradm  in a clean fresh FC3 install

# cyradm
-bash: cyradm: command not found
# rpm -qf /usr/lib/cyrus-imapd/cyradm
cyrus-imapd-utils-2.2.6-2.FC3.6
# ls /usr/bin/cy*
/usr/bin/cytune

vs  FC2
$ ll /usr/bin/cyradm
lrwxrwxrwx  1 root root 25  6. Nov 21:15 /usr/bin/cyradm ->
../lib/cyrus-imapd/cyradm

Version-Release number of selected component (if applicable):
cyrus-imapd-utils-2.2.6-2.FC3.6

How reproducible:
Didn't try

Steps to Reproduce:
1. fresh clean install FC3
2. try to execute cyradm as usual

Actual Results:  $ cyradm
-bash: cyradm: command not found

# ln -s /usr/lib/cyrus-imapd/cyradm /usr/bin/

$ cyradm --user root 127.0.0.1
IMAP Password:

Expected Results:  the sysmlinks should be created while installation


Additional info:  component "cyrus-imapd-utils"  does not exist

Comment 1 John Dennis 2004-11-12 19:26:13 UTC
Thank you for your bug report.

You're right, that RPM does not have the link, but I can't explain
why. The link creation is in the spec file. If I build the rpm locally
the link is in the rpm. If I rebuild the rpm in the official build
system the link is in the rpm. I can't explain why that particular rpm
was missing the link, nor is it reproducible :-(

I'm going to close this bug as won't fix, not because I don't think
its important, but because I don't know what there is to fix. Unless
the official build system flakes out again is some weird way the link
should be in all future rpms. 

FWIW, cyrus-imap*2.2.6-2.FC3.8 is in rawhide, is otherwise identical
to 2.2.6-2.FC3.6 and has the link.


Note You need to log in before you can comment on or make changes to this bug.