Bug 138608 - "linux askmethod" does not work when the iso images are on a reiserfs FS
Summary: "linux askmethod" does not work when the iso images are on a reiserfs FS
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-10 07:52 UTC by Ben Hsu
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-10 14:35:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ben Hsu 2004-11-10 07:52:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3)
Gecko/20040913 Firefox/0.10.1

Description of problem:
Installing with the ISO files on a reiserfs system does not work, it
seems the installer is only trying to mount the filesystem as ext2 or FAT

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. place the ISO images in a directory on a reiserfs system (in my
case, the fs is on /dev/hda5 and the directory is "/tmp/isos"
2. burn first image to CD and boot from it
3. at the boot prompt, enter "linux askmethod" (I also tried "linux
askmethod reiser" amd "linux askmethod reiserfs"
4. click through the menus, when prompted for location of images,
select "Hard Drive", then give the device (/dev/hda5) and directory (I
tried both "tmp/isos" and "/tmp/isos"
5. click to proceed
    

Actual Results:  installer gives an error message that the directory
/tmp/hdimage/tmp/isos does not exist. Alt-tabbing over to the install
log, VFS is complaining that it cannot find an ext2 filesystem or a
FAT filesystem on that device

Expected Results:  installation should proceed. maybe the user should
be allowed to specify the filesystem type?

Additional info:

Comment 1 Jeremy Katz 2004-11-10 14:35:45 UTC
We don't have the space for the reiserfs modules to be in the initrd.  


Note You need to log in before you can comment on or make changes to this bug.