Bug 138609 - request for dialog box message to be localised
Summary: request for dialog box message to be localised
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: usermode   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-10 08:03 UTC by Lawrence Lim
Modified: 2014-03-26 00:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-11 08:42:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pam-panel in ko locale (226.04 KB, image/png)
2004-11-10 08:04 UTC, Lawrence Lim
no flags Details

Description Lawrence Lim 2004-11-10 08:03:36 UTC
Description of problem:
At the moment, the message in the dialog box asking whether to keep or
forget authorisation is not localised. Is it possible for it to be
localised for the 14 locales supported by RHEL?

Version-Release number of selected component (if applicable):
usermode-gtk-1.74-1

How reproducible:
Always

Steps to Reproduce:
1.click on the icon in the systray
2.
3.
  
Actual results:
the message is in english. please see screenshot.

Expected results:
message is localised

Additional info:

Comment 1 Lawrence Lim 2004-11-10 08:04:17 UTC
Created attachment 106394 [details]
pam-panel in ko locale

Comment 2 Sarah Wang 2004-11-10 09:57:33 UTC
The translation is complete for all 14 supported languages:
[sarahs@cpe-147-10-88-201 usermode]$ make report
ja: 93 translated messages. (v1.48, last updated on 4/10/04)
ko: 93 translated messages. (v1.56, last updated on 22/10/04)
zh_CN: 93 translated messages. (v1.15, last updated on 7/10/04)
zh_TW: 93 translated messages. (v1.24, last updated on 4/10/04)
pt_BR: 93 translated messages. (v1.33, last updated on 5/10/04)
es: 93 translated messages. (v1.43, last updated on 29/10/04)
de: 93 translated messages. (v1.47, last updated on 6/10/04)
fr: 93 translated messages. (v1.49, last updated on 13/10/04)
it: 93 translated messages. (v1.43, last updated on 11/10/04)
hi: 93 translated messages. (v1.5, last updated on 6/10/04)
gu: 93 translated messages. (v1.4, last updated on 4/10/04)
bn: 93 translated messages. (v1.6, last updated on 5/10/04)
pa: 93 translated messages. (v1.9, last updated on 28/10/04)
ta: 93 translated messages. (v1.6, last updated on 25/10/04)

Please make sure using latest po files when building the package.

Comment 3 Jindrich Novy 2004-11-10 11:04:12 UTC
Hello Sarah, Lawrence,

I have fixed the translation in pam-panel-icon. English messages were
shown instead of translated because there was no set_locale(),
bindtextdomain() calls needed to enable translations. The full
localization should no longer be a problem.

I'll close this bug after I build the new usermode.

greetings,
Jindrich

Comment 4 Jindrich Novy 2004-11-10 15:19:47 UTC
Sarah,

more recent po files were available for:
zh_TW, last updated on 5/10/04
de, last updated on 7/10/04

so I included them.

Comment 5 Sarah Wang 2004-11-10 22:18:01 UTC
Thank you Jindrich!

Sarah


Note You need to log in before you can comment on or make changes to this bug.