Bug 138641 - TypeError: getSolutions() got an unexpected keyword argument 'progressCallback'
TypeError: getSolutions() got an unexpected keyword argument 'progressCallback'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-10 08:44 EST by Kaj J. Niemi
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-02 15:34:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kaj J. Niemi 2004-11-10 08:44:49 EST
Description of problem:
With up2date 4.3.52, up2date bombs every now and then with the
following traceback:

Downloading headers to solve dependencies...
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1245, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 800, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 1119, in batchRun
    batch.run()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 74, in run
    self.__dryRun()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 159, in
__dryRun
    self.percentCallback)
  File "/usr/share/rhn/up2date_client/up2date.py", line 386, in dryRun
    ret = depsolve.solvedep()
  File "/usr/share/rhn/up2date_client/depSolver.py", line 553, in solvedep
    ret = self.process_deps(deps)
  File "/usr/share/rhn/up2date_client/depSolver.py", line 520, in
process_deps
    changed = self.__dependencies(dependencies)
  File "/usr/share/rhn/up2date_client/depSolver.py", line 307, in
__dependencies
    msgCallback = self.msgCallback)
  File "/usr/share/rhn/up2date_client/depSolver.py", line 93, in solveDep
    msgCallback = msgCallback)
  File
"/usr/share/rhn/up2date_client/repoBackends/genericSolveDep.py", line
44, in solveDep
    msgCallback = self.msgCallback)
TypeError: getSolutions() got an unexpected keyword argument
'progressCallback'
Comment 1 Chris Runge 2004-11-20 12:22:38 EST
I'm also seeing this with RHEL 4 Beta 2 and up2date-4.3.53-1. The
error occurs after downloading headers to solve dependencies.
Comment 2 Adrian Likins 2004-11-22 12:36:25 EST
should be fixed in 4.3.65 (somewhere earlier actually, but
4.3.65 is headed to rhel-4)
Comment 3 Kaj J. Niemi 2004-12-02 15:34:44 EST
works for me in 4.3.69.. thanks :)
Comment 4 Jos Vos 2005-03-20 14:51:11 EST
What was the fix?  I see exact the same error in up2date 4.4.5-1 appearing in
RHEL4, when using it with yum repositories (of that matters).
Comment 5 Jos Vos 2005-03-21 08:46:08 EST
This seems to be fixed (again?) in 4.4.9-1.
Comment 6 Jos Vos 2005-03-21 09:05:48 EST
Ignore my last two comments.  When enabling "rpmmd" in repoDirector.py,
unexpected results occur, *even* with non-rpmmd repositories :-(.  Will try to
fix that, so this story may continue in bug #135121.

Note You need to log in before you can comment on or make changes to this bug.