Bug 1386434 - amanda-3.4 is available
Summary: amanda-3.4 is available
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: amanda
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Josef Ridky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: FutureFeature, Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-19 00:12 UTC by Upstream Release Monitoring
Modified: 2017-01-13 07:20 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-01-13 02:23:20 UTC


Attachments (Terms of Use)
Rebase-helper rebase-helper-debug.log log file. See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues. (24.54 KB, patch)
2016-10-19 00:14 UTC, Upstream Release Monitoring
no flags Details | Diff
Patch I'm using (4.41 KB, patch)
2016-11-10 01:41 UTC, Jason Tibbitts
no flags Details | Diff

Description Upstream Release Monitoring 2016-10-19 00:12:29 UTC
Latest upstream release: 3.4
Current version/release in rawhide: 3.3.9-3.fc26
URL: http://www.amanda.org

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/9324/

Comment 1 Upstream Release Monitoring 2016-10-19 00:14:15 UTC
Patching or scratch build for amanda-3.3.9 failed.

Comment 2 Upstream Release Monitoring 2016-10-19 00:14:18 UTC
Created attachment 1211921 [details]
Rebase-helper rebase-helper-debug.log log file.
See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues.

Comment 3 Upstream Release Monitoring 2016-10-19 00:14:21 UTC
Following patches has been deleted:
['PerlTidy.patch']

Comment 4 Upstream Release Monitoring 2016-10-20 08:13:59 UTC
jridky's amanda-3.4-1.fc26 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=811376

Comment 5 Fedora Update System 2016-10-22 02:25:26 UTC
amanda-3.4-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-85c6828deb

Comment 6 Fedora Update System 2016-10-22 03:55:09 UTC
amanda-3.4-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-bd11a142bc

Comment 7 Fedora Update System 2016-10-22 11:54:37 UTC
amanda-3.4-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3fad1b5e39

Comment 8 Upstream Release Monitoring 2016-10-24 10:38:45 UTC
jridky's amanda-3.4-2.fc26 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=812127

Comment 9 Upstream Release Monitoring 2016-10-28 00:23:52 UTC
jridky's amanda-3.4-3.fc26 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=812789

Comment 10 Fedora Update System 2016-10-31 09:25:38 UTC
amanda-3.4-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-43c5b0cd39

Comment 11 Fedora Update System 2016-10-31 09:25:50 UTC
amanda-3.4-3.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-1a2eec473d

Comment 12 Fedora Update System 2016-10-31 09:25:57 UTC
amanda-3.4-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-c496e020d0

Comment 13 Fedora Update System 2016-11-01 02:21:04 UTC
amanda-3.4-3.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-1a2eec473d

Comment 14 Fedora Update System 2016-11-01 18:19:28 UTC
amanda-3.4-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-c496e020d0

Comment 15 Fedora Update System 2016-11-01 18:21:58 UTC
amanda-3.4-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-43c5b0cd39

Comment 16 Jason Tibbitts 2016-11-01 19:14:39 UTC
Not sure how better to talk about this, but something is definitely not right with the updated packages and I would request that you reconsider trying to push them as an update in their current state.

Somehow updating a basic client which has only amanda, amanda-client and amanda-libs brings in amanda-server.  In turn, that appears to bring in a web server, mod perl, and a large number of Perl modules.  For the backup server, that might be considered OK (though I'd suggest doing that only in rawhide) but I don't think this is at all reasonable for a simple client install.

Comment 17 Jason Tibbitts 2016-11-02 01:40:14 UTC
So the issue is the following dependencies that the base amanda package has grown, which are only satisfied by amanda-server:

perl(Amanda::Changer)
perl(Amanda::Cmdfile)
perl(Amanda::Cmdline)
perl(Amanda::Device)
perl(Amanda::Disklist)
perl(Amanda::Extract)
perl(Amanda::Holding)
perl(Amanda::Logfile)
perl(Amanda::Recovery::Clerk)
perl(Amanda::Recovery::Clerk::Feedback)
perl(Amanda::Recovery::Planner)
perl(Amanda::Recovery::Scan)
perl(Amanda::Storage)

I'm not exactly sure why the client would need some of those, but I'd suggest moving them into the base amanda package or the libs package.

And I'll add these while I'm typing, though I should find the time to open separate tickets:

Just putting the perl .so files in -libs while the actual libraries are in the base amanda package is very strange.  Probably putting it all in a perl-Amanda package would make more sense.

The odd patch to add the empty package statements to work around the dependency breakage is probably handled more simply by a simple dependency filter in the spec.

I always have to rebuild locally to add a build dependency on xfsdump.  xfsdump is the default filesystem for Fedora Server; it doesn't make a lot of sense for amanda to lack support for it.

If I can find some time I'll work up and send some patches.

Comment 18 Jason Tibbitts 2016-11-10 01:41 UTC
Created attachment 1219122 [details]
Patch I'm using

I had typed up a big comment up but somehow never actually hit the Submit button.  In the interim I've been running packages built with the attached patch to the spec and everything's working fine without pointless dependencies.

What I ended up doing is moving _all_ of the Perl stuff to the base amanda package by adding these two lines to the %files section:

%{perl_vendorarch}/Amanda¬
%{perl_vendorarch}/auto/Amanda¬

And then removing all other lines matching perl_vendorarch.  This gives me a set of packages that has only one additional dependency (perl-JSON).

Really, the amanda-libs package should probably just go away entirely and its contents moved into the base amanda package.

Comment 19 Upstream Release Monitoring 2016-11-10 09:10:38 UTC
jridky's amanda-3.4-4.fc26 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=816787

Comment 20 Josef Ridky 2016-11-10 09:16:45 UTC
Thanks for your patch. It has been applied in the latest build.

Comment 21 Fedora Update System 2016-11-10 12:09:43 UTC
amanda-3.4-4.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-dc749673ba

Comment 22 Fedora Update System 2016-11-10 12:09:55 UTC
amanda-3.4-4.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-a419e39312

Comment 23 Fedora Update System 2016-11-10 12:10:04 UTC
amanda-3.4-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-20e7a98102

Comment 24 Fedora Update System 2016-11-10 19:27:26 UTC
amanda-3.4-4.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-a419e39312

Comment 25 Fedora Update System 2016-11-11 04:23:33 UTC
amanda-3.4-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-20e7a98102

Comment 26 Fedora Update System 2016-11-11 05:02:20 UTC
amanda-3.4-4.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-dc749673ba

Comment 27 Upstream Release Monitoring 2016-11-16 10:22:11 UTC
jridky's amanda-3.4-5.fc26 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=818244

Comment 28 Fedora Update System 2016-11-16 15:14:57 UTC
amanda-3.4-5.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-6a645d2a8d

Comment 29 Fedora Update System 2016-11-16 15:15:14 UTC
amanda-3.4-5.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-fab8484e81

Comment 30 Fedora Update System 2016-11-16 15:15:26 UTC
amanda-3.4-5.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-777aa767bb

Comment 31 Fedora Update System 2016-11-17 03:53:19 UTC
amanda-3.4-5.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-fab8484e81

Comment 32 Fedora Update System 2016-11-17 03:58:27 UTC
amanda-3.4-5.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-777aa767bb

Comment 33 Fedora Update System 2016-11-21 21:10:29 UTC
amanda-3.4-5.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-6a645d2a8d

Comment 34 Fedora Update System 2016-12-07 10:30:43 UTC
amanda-3.4.1-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-3439f8eaaa

Comment 35 Fedora Update System 2016-12-07 10:31:03 UTC
amanda-3.4.1-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d77b59754e

Comment 36 Fedora Update System 2016-12-07 10:31:20 UTC
amanda-3.4.1-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-131de8f07a

Comment 37 Fedora Update System 2016-12-08 04:52:13 UTC
amanda-3.4.1-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d77b59754e

Comment 38 Fedora Update System 2016-12-08 04:55:52 UTC
amanda-3.4.1-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3439f8eaaa

Comment 39 Fedora Update System 2016-12-08 06:22:04 UTC
amanda-3.4.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-131de8f07a

Comment 40 Fedora Update System 2017-01-13 02:23:20 UTC
amanda-3.4.1-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 41 Fedora Update System 2017-01-13 07:20:40 UTC
amanda-3.4.1-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.