Bug 138646 - clicking on pdf bookmarks always opens page 1
clicking on pdf bookmarks always opens page 1
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gpdf (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Marco Pesenti Gritti
:
: 141420 141878 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-10 09:45 EST by Gustavo J. A. M. Carneiro
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-19 15:13:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
One-liner that seems to do the trick (606 bytes, patch)
2004-12-30 07:34 EST, Anders Berg
no flags Details | Diff

  None (edit)
Description Gustavo J. A. M. Carneiro 2004-11-10 09:45:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020 Galeon/1.3.17.99

Description of problem:
The bookmarks side panel is not working correctly.  The bookmarks show
up correctly, but clicking on any bookmark always switches the viewer
to page 1, instead of the correct page.

Version-Release number of selected component (if applicable):
gpdf-2.8.0-8

How reproducible:
Always

Steps to Reproduce:
1. Open a PDF with bookmarks
2. Click on a bookmark

    

Actual Results:  Viewer jumps to page 1

Expected Results:  Viewer jumps to pointed to page

Additional info:
Comment 1 Dan Williams 2004-11-17 13:25:44 EST
Mass reassign to Marco.
Comment 2 Rudi Chiarito 2004-12-04 18:47:43 EST
I can see this with a variety of files. It was also reported in bugs
141420 and 141878.
Comment 3 Marco Pesenti Gritti 2004-12-06 16:18:17 EST
*** Bug 141420 has been marked as a duplicate of this bug. ***
Comment 4 Marco Pesenti Gritti 2004-12-06 17:36:42 EST
*** Bug 141878 has been marked as a duplicate of this bug. ***
Comment 5 Anders Berg 2004-12-30 07:34:49 EST
Created attachment 109176 [details]
One-liner that seems to do the trick

I've added a one-liner patch that seems make bookmarks work. It seems you can't
trust gtk_tree_selection_get_selected() NOT to update the GtkTreeIter*
parameter when returning FALSE.
Comment 6 Marco Pesenti Gritti 2005-01-03 06:22:44 EST
I added a patch to http://bugzilla.gnome.org/show_bug.cgi?id=159937
Comment 7 Marco Pesenti Gritti 2005-01-10 06:26:20 EST
Updates for FC2/FC3 will be available soon. Testing would be very welcome.

I think this is worth a rhel4 errata too.

Note You need to log in before you can comment on or make changes to this bug.