Bug 138674 - hdparm errors with SATA disks (sata_sis)
hdparm errors with SATA disks (sata_sis)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hdparm (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
:
: 142121 172764 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-10 12:01 EST by R.Smith
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-25 09:10:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description R.Smith 2004-11-10 12:01:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
When performing, as root, hdparm -tT /dev/sda, I get several
'operation not supported' messages during the benchmarks relating to
'BLKFLSBUF' and 'HDIO_DRIVE_CMD(null)'. As I recall, this didn't
happen with FC2. My hardware is:

Motherboard: ASRock K7S8XE+ (onboard SiS 180 SATA/PATA controller)
Harddisk: Samsung SP0812C SATA

Version-Release number of selected component (if applicable):
hdparm-5.7-2

How reproducible:
Always

Steps to Reproduce:
1. Log in as root.
2. Type: hdparm -tT /dev/sda.
3. Wait for the benchmark to perform.
    

Actual Results:  [root@cpc1-whit1-5-0-cust140 ~]# hdparm -tT /dev/sda

/dev/sda:
 Timing cached reads:   1020 MB in  2.00 seconds = 508.81 MB/sec
BLKFLSBUF failed: Operation not supported
HDIO_DRIVE_CMD(null) (wait for flush complete) failed: Operation not
supported
 Timing buffered disk reads:  356 MB in  3.02 seconds = 117.86 MB/sec
BLKFLSBUF failed: Operation not supported
HDIO_DRIVE_CMD(null) (wait for flush complete) failed: Operation not
supported

Expected Results:  No error messages at all.

Additional info:
Comment 1 teuben 2004-11-25 08:22:24 EST
I have the same problem, but an additional noteworthy thing is that
the cached reads seems to give the correct result, but the buffered
disk reads seem not reset the amount that was read. Thus in subsequent
runs you will see the I/O speed linearly increase!!!

Timing buffered disk reads:  156 MB in  3.06 seconds =  50.90 MB/sec
Timing buffered disk reads:  302 MB in  3.01 seconds = 100.45 MB/sec
Timing buffered disk reads:  442 MB in  3.02 seconds = 146.19 MB/sec
....

Timing buffered disk reads:  430 MB in  3.00 seconds = 143.12 MB/sec
Timing buffered disk reads:  554 MB in  3.03 seconds = 182.81 MB/sec
Timing buffered disk reads:  670 MB in  3.00 seconds = 223.07 MB/sec
...

initially i thought it would continue to accumulate, but these two triplets
of observations were made about 12 hours apart, so clearly the last
one at 442MB and 12 hours later at 430MB do show that this buffer
does get cleared (partially) from time to time?

I have had no chance to test if regular (P)ATA drives suffer from the same
problem.
Comment 2 higezo 2004-11-25 23:51:40 EST
I have got the same errors on FC3 of x86_64 platform.

# hdparm -tT /dev/sda

/dev/sda:
 Timing cached reads:   2156 MB in  2.00 seconds = 1076.55 MB/sec
BLKFLSBUF failed: Operation not supported
HDIO_DRIVE_CMD(null) (wait for flush complete) failed: Operation not
supported
 Timing buffered disk reads:  204 MB in  3.01 seconds =  67.83 MB/sec
BLKFLSBUF failed: Operation not supported
HDIO_DRIVE_CMD(null) (wait for flush complete) failed: Operation not
supported

My Hardwares:

CPU Athlon64 3400+
MotherBoard GA-K8VT800M
HDD WD740GD(Raptor)
Comment 3 Karsten Hopp 2004-12-07 10:40:54 EST
*** Bug 142121 has been marked as a duplicate of this bug. ***
Comment 5 Karsten Hopp 2005-11-09 05:57:48 EST
*** Bug 172764 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.