Bug 138682 - /sbin/dhclient-script specifies incorrect location for ntp driftfile
/sbin/dhclient-script specifies incorrect location for ntp driftfile
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: dhcp (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-10 12:52 EST by Daniel Thom
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-22 12:03:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Thom 2004-11-10 12:52:42 EST
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux; x86_64) 
(KHTML, like Gecko) 
 
Description of problem: 
dhclient-script generated the following /etc/ntp.conf on my RHEL 3 
Update 3 machine: 
 
# generated by /sbin/dhclient-script 
restrict default ignore 
restrict 127.0.0.1 
driftfile /etc/ntp/data/drift 
broadcastdelay 0.008 
authenticate yes 
keys /etc/ntp/keys 
restrict 10.1.0.12 nomodify notrap noquery 
server 10.1.0.12 
 
The driftfile location does not exist and is different from the 
default ntp.conf file which points to /var/lib/ntp/drift which does 
exist. 
 
I checked my Fedora Core 3 Test 3 machine and it looks like the 
correct behavior happens there.  That is running dhclient-3.0.1-9. 
 
Version-Release number of selected component (if applicable): 
dhclient-3.0pl2-6.14.1 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. Configure eth0 for dhcp with a dhcp server that hands out NTP 
information. 
2. Run 'ifup eth0' 
3. Rinse and repeat. 
     
 
Additional info: 
 
The problem in dhclient-script is obvious and easily repaired as it 
just has the wrong string in the here document it writes to ntp.conf.
Comment 1 Jason Vas Dias 2004-11-10 13:46:10 EST
 dhcp-3.0.1-10_EL3 is now the latest version of dhcp for RHEL-3 and
 is in RHEL-3-U4, and does not have this problem.
 It can also be downloaded from:
    http://people.redhat.com/~jvdias/DHCP/RHEL-3
Comment 2 Daniel Thom 2004-11-10 15:43:28 EST
Excellent, thanks for the info, sorry for the redundant bug!  One 
quick question though, is there currently a release version of this 
for RHEL-3?  I saw a beta on RHN (dhcp-3.0.1-10_EL3:7 Red Hat 
Enterprise Linux AS (v. 3 for x86) Beta), but not one marked as 
release? 
Comment 3 Jason Vas Dias 2004-11-10 16:19:07 EST
 RHEL-3-U4 is still in 'beta' testing, so hence the 'beta' status
 of the dhcp-3.0.1-10_EL3 rpm you found, which is identical to the
 one available through this link:
   http://people.redhat.com/~jvdias/DHCP/RHEL-3
 Quite a few customers have downloaded and are using this version.
 It's up to you whether to download and try it now or wait until
 RHEL-3-U4 is officially released.

Note You need to log in before you can comment on or make changes to this bug.