Bug 138684 - Update using update ISO
Update using update ISO
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-packages (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-10 13:05 EST by BEA Boulder
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 16:33:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description BEA Boulder 2004-11-10 13:05:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
It would be very nice to have redhat-config-packages be capable of 
updating using update ISO's e.g. update RH ES 3 Update 2 to Update 3. 
Support for --isodir is there but "update" button is not functional. 
There are tricks available but this should be supported out of the 
box.

Version-Release number of selected component (if applicable):
1.29.2-1

How reproducible:
Always

Steps to Reproduce:
1. Have RH ES 3 Update 2 system
2. Get ISO's for Update 3
3. redhat-config-packages --isodir=$PATH_TO_UPDATE_3_ISOS
    

Actual Results:  Update button is hobbled

Expected Results:  Update to Update 3

Additional info:
Comment 1 Jeremy Katz 2004-11-10 13:09:57 EST
system-config-packages doesn't at present support upgrades.  It's in
the plans for eventually, but requires a fair bit of work to get to be
"sane"
Comment 2 BEA Boulder 2004-11-10 17:58:28 EST
Thank you for response. Anaconda "linux upgrade" works for RH ES U2 
to U3 update in our environment in spite of the boilerplate warning 
in the release notes.

Note You need to log in before you can comment on or make changes to this bug.