Bug 138689 - apol - tcl/tk error when selecting rule types
Summary: apol - tcl/tk error when selecting rule types
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: setools (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-10 18:49 UTC by Don Patterson
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version: 1.5.1-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-04 23:28:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix apol GUI bug (592 bytes, patch)
2004-11-10 18:51 UTC, Don Patterson
no flags Details | Diff

Description Don Patterson 2004-11-10 18:49:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.1.4322)

Description of problem:
Apol renders a tcl/tk application error when selecting the rule type 
checkbuttons under the TE Rules tab. This is because it is calling a 
bad tcl procedure name. 

Version-Release number of selected component (if applicable):
setools-1.5.1

How reproducible:
Always

Steps to Reproduce:
1.Start apol and open a policy.
2.Go to the Policy Rules->TE Rules tab and select the 
Classes/Permissions subtab
3.Select an object class. The permissions listbox should now be 
enabled.
4.Deselect the 'allow' checkbutton under the Rule Selection frame.
4.
    

Actual Results:  invalid command name "SEUser_Top::enable_tkListbox"

Expected Results:  A tcl/tk error should not pop up.

Additional info:

Comment 1 Don Patterson 2004-11-10 18:51:00 UTC
Created attachment 106432 [details]
Patch to fix apol GUI bug

Comment 2 Daniel Walsh 2004-11-10 19:54:00 UTC
Added patch in setools-1.5.1-3


Note You need to log in before you can comment on or make changes to this bug.