Bug 138695 - Bug in scsi.c - libata issue?
Bug in scsi.c - libata issue?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Garzik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-10 14:12 EST by Pete Robinson
Modified: 2013-07-02 22:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-24 02:44:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Robinson 2004-11-10 14:12:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
SATA HD on SIS964 controller, HD Maxtor 6Y200M0 (x2)
FC installed to 2nd HD, first HD has XP 

output of dmesg:

drivers/scsi/scsi_lib.c:343:
spin_lock(drivers/scsi/libata-core.c:03b80d80) already locked by
drivers/scsi/libata-core.c/2913
drivers/scsi/libata-core.c:2928:
spin_unlock(drivers/scsi/libata-core.c:03b80d80) not locked
ata1: command 0x25 timeout, stat 0x50 host_stat 0x21
Assertion failed! qc->flags &
ATA_QCFLAG_ACTIVE,drivers/scsi/libata-core.c,ata_qc_complete,line=2546
------------[ cut here ]------------
kernel BUG at drivers/scsi/scsi.c:284!
invalid operand: 0000 [#1]
Modules linked in: parport_pc lp parport autofs4 sunrpc ipt_REJECT
ipt_state ip_conntrack iptable_filter ip_tables button battery ac
joydev md5 ipv6 ohci1394 ieee1394 ohci_hcd ehci_hcd snd_usb_audio
snd_usb_lib snd_intel8x0 snd_ac97_codec snd_pcm_oss snd_mixer_oss
snd_pcm snd_timer snd_page_alloc gameport snd_mpu401_uart snd_rawmidi
snd_seq_device snd soundcore sis900 floppy dm_snapshot dm_zero
dm_mirror ext3 jbd dm_mod sata_sis libata sd_mod scsi_mod
CPU:    0
EIP:    0060:[<4281a4cd>]    Not tainted VLI
EFLAGS: 00010046   (2.6.9-1.667)
EIP is at scsi_put_command+0xa4/0x22b [scsi_mod]
eax: 41dd8800   ebx: 41dd7000   ecx: 41df5950   edx: 41df5950
esi: 41df5940   edi: 00000202   ebp: 41df5940   esp: 41df4ef0
ds: 007b   es: 007b   ss: 0068
Process scsi_eh_0 (pid: 184, threadinfo=41df4000 task=03bb57f0)
Stack: 41d2c720 40b5e72c 00000202 428200fb 41d2c720 428202c0 00000001
00000000
       40b5e72c 41df5940 42820621 00000001 00006b44 00000246 00000001
40b5e72c
       41d2c720 00000000 00000000 00000200 00000000 00000000 41dd7000
41df5940
Call Trace:
 [<428200fb>] scsi_next_command+0xc/0x14 [scsi_mod]
 [<428202c0>] scsi_end_request+0x19b/0x1a2 [scsi_mod]
 [<42820621>] scsi_io_completion+0x227/0x433 [scsi_mod]
 [<4281b0be>] scsi_finish_command+0xad/0xb1 [scsi_mod]
 [<42877eea>] ata_scsi_qc_complete+0x28/0x2d [libata]
 [<42876599>] ata_qc_complete+0x4d/0xa1 [libata]
 [<42877a8b>] ata_scsi_error+0xf/0x22 [libata]
 [<4281f288>] scsi_error_handler+0x131/0x191 [scsi_mod]
 [<0211b3d9>] schedule_tail+0xc/0x37
 [<4281f157>] scsi_error_handler+0x0/0x191 [scsi_mod]
 [<021041d9>] kernel_thread_helper+0x5/0xb
Code: 83 c4 1c 8b 46 04 8d 56 10 c7 40 38 01 00 00 00 8b 46 04 c7 40
44 99 48 82 42 8b 46 04 c7 40 48 1b 01 00 00 8b 4e 10 39 d1 75 08 <0f>
0b 1c 01 99 48 82 42 8b 42 04 89 41 04 89 08 89 52 04 8b 46


Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
seems to occur during some disk accesses ...


Additional info:
Comment 1 Dave Jones 2004-11-20 01:54:53 EST
does this still happen with todays errata kernel ?
(currently in testing repo, but due to move to updates proper real soon)
Comment 2 Pete Robinson 2004-11-21 11:14:31 EST
sorry, which version of the kernel is that?

I can see one released on 18/11 -> kernel-2.6.9-1.681_FC3.i586.rpm

I've also tried 2.6.9-1.678_FC3 - but cannot get this to load as it
doesn't find the lvm volumes...
Comment 3 Dave Jones 2005-02-24 01:26:29 EST
any better with teh 2.6.10 updates ?
Comment 4 Pete Robinson 2005-02-24 02:44:22 EST
not seen any instances of the issue at all! thanks.

Note You need to log in before you can comment on or make changes to this bug.