Bug 138717 - Disk errors not trapped
Summary: Disk errors not trapped
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-10 20:43 UTC by nathan black
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-11 18:39:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description nathan black 2004-11-10 20:43:52 UTC
Description of problem:
During install, if the hard drive is failing to write or read, the
install does not stop.

Version-Release number of selected component (if applicable):
FC3 Gold

How reproducible:
Attempt installing on failing hard drive. When drive blocks are
failing the writes the install does not report an error to the user. 

Steps to Reproduce:
1. use faulty disk i.e. /dev/hda
2. watch syslog for io errors on device
3. watch installer not report error to the user
  
Actual results:
eventual crash of installer and reboot requested when X exits

Expected results:
a message telling the user that anaconda was not able to install
packages due to excessive IO errors on the destination.

Additional info:
Write errors should be trapped and returned to the user as a simple to
read error.  i.e. Hey look, I was trying to write to your drive and it
told me it was unable to do so.  or check the S.M.A.R.T. drive
registers to do predictive failure (idea)

Comment 1 Jeremy Katz 2004-11-11 18:39:52 UTC
Unfortunately, the kernel doesn't really pass this information up in
any sort of useful way for userspace to get at.  And parsing logs
isn't good enough (since there are cases with empty drives where you
get read errors that look just like bad drives.  *sigh*)


Note You need to log in before you can comment on or make changes to this bug.