Bug 1387276 - Doesn't start
Summary: Doesn't start
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: freemind
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Simacek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-20 14:05 UTC by Jiri Popelka
Modified: 2016-11-19 21:13 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-19 21:05:55 UTC


Attachments (Terms of Use)

Description Jiri Popelka 2016-10-20 14:05:17 UTC
Version-Release number of selected component (if applicable):
freemind-1.0.1-10.fc24.noarch
but it's Fedora 25 (freemind hasn't been rebuilt for F25 yet).

Actual results:
$freemind
Checking Java Version...

STDOUT: User patterns file /home/jpopelka/.freemind/patterns.xml not found.
STDOUT: User patterns file /home/jpopelka/.freemind/patterns.xml not found.
STDERR: java.lang.reflect.InvocationTargetException
STDERR: 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
STDERR: 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
STDERR: 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
STDERR: 	at java.lang.reflect.Method.invoke(Method.java:498)
STDERR: 	at freemind.main.FreeMindStarter.main(FreeMindStarter.java:90)
STDERR: Caused by: java.lang.NoClassDefFoundError: org/dpolivaev/mnemonicsetter/MnemonicSetter
STDERR: 	at com.lightdev.app.shtm.DynamicResource.createMenu(DynamicResource.java:190)
STDERR: 	at com.lightdev.app.shtm.DynamicResource.createMenubar(DynamicResource.java:151)
STDERR: 	at com.lightdev.app.shtm.SHTMLPanelImpl.<init>(SHTMLPanelImpl.java:236)
STDERR: 	at com.lightdev.app.shtm.SHTMLPanelSingleDocImpl.<init>(SHTMLPanelSingleDocImpl.java:24)
STDERR: 	at com.lightdev.app.shtm.SHTMLPanel.createSHTMLPanel(SHTMLPanel.java:56)
STDERR: 	at accessories.plugins.NodeNoteRegistration.getHtmlEditorPanel(NodeNoteRegistration.java:487)
STDERR: 	at accessories.plugins.NodeNoteRegistration.getNoteViewerComponent(NodeNoteRegistration.java:481)
STDERR: 	at accessories.plugins.NodeNoteRegistration.register(NodeNoteRegistration.java:323)
STDERR: 	at freemind.modes.mindmapmode.MindMapController.startupController(MindMapController.java:716)
STDERR: 	at freemind.controller.Controller.afterMapModuleChange(Controller.java:607)
STDERR: 	at freemind.controller.MapModuleManager$MapModuleChangeObserverCompound.afterMapModuleChange(MapModuleManager.java:126)
STDERR: 	at freemind.controller.MapModuleManager.setMapModule(MapModuleManager.java:403)
STDERR: 	at freemind.controller.MapModuleManager.newMapModule(MapModuleManager.java:246)
STDERR: 	at freemind.modes.ControllerAdapter.newMap(ControllerAdapter.java:402)
STDERR: 	at freemind.modes.ControllerAdapter.load(ControllerAdapter.java:425)
STDERR: 	at freemind.modes.ControllerAdapter.load(ControllerAdapter.java:439)
STDERR: 	at freemind.modes.mindmapmode.MindMapMode.restore(MindMapMode.java:81)
STDERR: 	at freemind.controller.LastOpenedList.open(LastOpenedList.java:126)
STDERR: 	at freemind.main.FreeMind.loadMaps(FreeMind.java:1209)
STDERR: 	at freemind.main.FreeMind.main(FreeMind.java:924)
STDERR: 	... 5 more
STDERR: Caused by: java.lang.ClassNotFoundException: org.dpolivaev.mnemonicsetter.MnemonicSetter
STDERR: 	at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
STDERR: 	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
STDERR: 	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
STDERR: 	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
STDERR: 	... 25 more

Comment 1 Fedora Update System 2016-10-22 23:23:21 UTC
freemind-1.0.1-11.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-55802ff79e

Comment 2 Fedora Update System 2016-10-26 22:30:26 UTC
freemind-1.0.1-11.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 3 Jiri Popelka 2016-10-29 12:28:50 UTC
Michael, there's [1] no freemind package and none of the subpackages provide it.
I guess you need to add empty %files section, so the main package gets actually created.

[1] http://koji.fedoraproject.org/koji/buildinfo?buildID=811782

Comment 4 Michael Simacek 2016-10-31 08:36:31 UTC
Ah, you're right. I checked everything I built, but I didn't check that I built everything. Thanks for noticing. (now I'm wondering what the bodhi upgrade checks do)

Comment 5 Fedora Update System 2016-10-31 09:12:28 UTC
freemind-1.0.1-12.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-c8ba3a0eb5

Comment 6 Fedora Update System 2016-11-01 02:21:00 UTC
freemind-1.0.1-12.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-c8ba3a0eb5

Comment 7 Fedora Update System 2016-11-07 11:18:45 UTC
freemind-1.0.1-13.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-dc18fa725d

Comment 8 Fedora Update System 2016-11-07 18:22:16 UTC
freemind-1.0.1-13.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-dc18fa725d

Comment 9 Fedora Update System 2016-11-19 21:05:55 UTC
freemind-1.0.1-12.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2016-11-19 21:13:13 UTC
freemind-1.0.1-13.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.