Bug 138759 - gnome cannot eject CDROM and zip disk
Summary: gnome cannot eject CDROM and zip disk
Status: CLOSED DUPLICATE of bug 122472
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus   
(Show other bugs)
Version: 3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-11 00:24 UTC by Dmitri A. Sergatskov
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:06:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dmitri A. Sergatskov 2004-11-11 00:24:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
Right-click on the automounted CD and choosing "Eject" causes CDROM
to be unmounted, but not ejected. "Unable to eject media" pops-up.
The same problem with zip disk (usb).

Version-Release number of selected component (if applicable):
gnome-*-2.6.0-3

How reproducible:
Always

Steps to Reproduce:
1.insert CD into cdrom
2. wait for it to automount
3. right-click on the icon on the desktop, select "Eject"
    

Actual Results:  CD unmounts, but does not eject. Error message
pops-up : "Unable to eject media".


Expected Results:  CDROM ejects.

Additional info:

This problew has been with zip disks for quite some time. I filed few
bug reports
with no result (the problem is still there).
This happens on multiple computers. CDROM is on ide interface.

Comment 1 David Balažic 2004-11-15 13:22:36 UTC
Same for me.

Fresh FC3/i386 install ( GNOME ).

 - insert CD
 - wait for icon appearing on desktop
 - right click, select Eject

It is umnounted, but not ejected, it gives an error dialog about
ejecting failed.

Happens with CD-RW and CD-ROM units ( ATAPI ).

Comment 2 William Lovaton 2004-12-01 02:38:57 UTC
Hey,

I have the same problem but for me is very occasional, It rarely
happens and always with the same CDs (they are a bit old and ugly). 
The ones I usually use works fine without any problem.

To be more specific about this problem the actual error message is:
"eject: unable to eject, last error: Invalid argument".

The CD got unmounted but the CD drive wont eject it.  I can eject it
as root in the console (# eject /dev/cdrom) and even in the console I
get the very same error message as in nautilus.

For more information please check this mail message:
http://www.redhat.com/archives/fedora-list/2004-November/msg06781.html


Comment 3 David Balažic 2004-12-01 08:49:03 UTC
The problem disappeared after updating my system. Don't know which
package did the trick, I installed a full CD of updates (official
updates from
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/3/i386/ ).

Comment 4 Alexander Larsson 2005-01-11 14:43:30 UTC
This looks like bug 122472. Marking duplicate, please see my last
question there.

*** This bug has been marked as a duplicate of 122472 ***

Comment 5 Red Hat Bugzilla 2006-02-21 19:06:54 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.