Bug 138771 - Nov 10 17:38:23 ser0_paco kernel: (scsi0:A:2:0): CDB: 0x28 0x0 0x2 0xa6 0x1a 0x5d 0x0 0x0 0x24 0x0 Nov 10 17:38:23 ser0_paco kernel: (scsi0:A:2:0): Saw underflow (4096 of 18432 bytes). Treated as error
Nov 10 17:38:23 ser0_paco kernel: (scsi0:A:2:0): CDB: 0x28 0x0 0x2 0xa6 0x1a ...
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Coughlan
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-10 20:36 EST by Rubén Dután
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-19 09:00:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
file messages (28.07 KB, text/plain)
2004-11-11 09:23 EST, Rubén Dután
no flags Details

  None (edit)
Description Rubén Dután 2004-11-10 20:36:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
Nov 10 17:38:23 ser0_paco kernel: (scsi0:A:2:0): CDB: 0x28 0x0 0x2
0xa6 0x1a 0x5d 0x0 0x0 0x24 0x0
Nov 10 17:38:23 ser0_paco kernel: (scsi0:A:2:0): Saw underflow (4096
of 18432 bytes). Treated as error


Version-Release number of selected component (if applicable):
kernel-2.4.21-4.EL

How reproducible:
Always

Steps to Reproduce:
1.Nov 10 17:31:24 ser0_paco kernel: (scsi0:A:2:0): CDB: 0x28 0x0 0x2
0xea 0x76 0x49 0x0 0x0 0x4 0x0
2.Nov 10 17:31:24 ser0_paco kernel: (scsi0:A:2:0): Saw underflow (2048
of 2048 bytes). Treated as error
3.Nov 10 17:31:44 ser0_paco kernel: (scsi0:A:2:0): CDB: 0x28 0x0 0x2
0x8b 0x60 0x2d 0x0 0x0 0xc 0x0
4.Nov 10 17:31:44 ser0_paco kernel: (scsi0:A:2:0): Saw underflow (2048
of 6144 bytes). Treated as error
5.Nov 10 17:32:18 ser0_paco kernel: (scsi0:A:2:0): CDB: 0x28 0x0 0x2
0x82 0xca 0x5 0x0 0x0 0x4 0x0
6.Nov 10 17:32:18 ser0_paco kernel: (scsi0:A:2:0): Saw underflow (2048
of 2048 bytes). Treated as error
7.Nov 10 17:32:30 ser0_paco kernel: (scsi0:A:2:0): CDB: 0x28 0x0 0x2
0xae 0xc6 0x39 0x0 0x0 0xc 0x0
8.Nov 10 17:32:30 ser0_paco kernel: (scsi0:A:2:0): Saw underflow (2048
of 6144 bytes). Treated as error
9.Nov 10 17:32:30 ser0_paco kernel: (scsi0:A:2:0): CDB: 0x28 0x0 0x2
0xae 0xc6 0x39 0x0 0x0 0xc 0x0
10.Nov 10 17:32:30 ser0_paco kernel: (scsi0:A:2:0): Saw underflow
(2048 of 6144 bytes). Treated as error


Additional info:
Comment 2 Tom Coughlan 2004-11-11 07:06:12 EST
Please provide more information about the hardware configuration.
Which HBA? what is it connected to? is this aic7xxx or aic79xx? Also
post /var/log/messages. 

If it is aic7xxx.o, you might try aic7xxx_old.o to see if the result
is different.

You are running the original, out-of-date, RHEL 3 kernel (Update 3 is
available and Update 4 is in beta test). The aic7xxx drivers are not
updated, though, so I don't think you will see any improvement from an
update.
Comment 3 Rubén Dután 2004-11-11 09:13:04 EST
Nov 10 17:53:21 ser0_paco kernel: scsi0 : Adaptec AIC7XXX EISA/VLB/PCI
SCSI HBA DRIVER, Rev 6.2.36
Nov 10 17:53:21 ser0_paco modprobe: modprobe: Can't locate module
char-major-188
Nov 10 17:53:21 ser0_paco kernel:         <Adaptec (Compaq OEM) 3960D
Ultra160 SCSI adapter>
Nov 10 17:53:21 ser0_paco modprobe: modprobe: Can't locate module
char-major-188
Nov 10 17:53:21 ser0_paco kernel:         aic7899: Ultra160 Wide
Channel A, SCSI Id=7, 32/253 SCBs
Nov 10 17:53:21 ser0_paco modprobe: modprobe: Can't locate module
char-major-188
Nov 10 17:53:21 ser0_paco kernel:
Nov 10 17:53:21 ser0_paco modprobe: modprobe: Can't locate module
char-major-188
Nov 10 17:53:21 ser0_paco kernel: scsi1 : Adaptec AIC7XXX EISA/VLB/PCI
SCSI HBA DRIVER, Rev 6.2.36
Nov 10 17:53:21 ser0_paco modprobe: modprobe: Can't locate module
char-major-188
Nov 10 17:53:21 ser0_paco kernel:         <Adaptec (Compaq OEM) 3960D
Ultra160 SCSI adapter>
Nov 10 17:53:21 ser0_paco modprobe: modprobe: Can't locate module
char-major-188
Nov 10 17:53:21 ser0_paco kernel:         aic7899: Ultra160 Wide
Channel B, SCSI Id=7, 32/253 SCBs
Nov 10 17:53:21 ser0_paco modprobe: modprobe: Can't locate module
char-major-188
Nov 10 17:53:21 ser0_paco kernel:
Nov 10 17:53:21 ser0_paco modprobe: modprobe: Can't locate module
char-major-188
Nov 10 17:53:21 ser0_paco kernel: Starting timer : 0 0
Nov 10 17:53:21 ser0_paco modprobe: modprobe: Can't locate module
char-major-188
Nov 10 17:53:21 ser0_paco kernel: blk: queue f6e69a18, I/O limit
524287Mb (mask 0x7fffffffff)
Nov 10 17:53:21 ser0_paco modprobe: modprobe: Can't locate module
char-major-188
Nov 10 17:53:21 ser0_paco kernel: (scsi0:A:0): 160.000MB/s transfers
(80.000MHz DT, offset 63, 16bit)
Nov 10 17:53:21 ser0_paco kernel: (scsi0:A:1): 160.000MB/s transfers
(80.000MHz DT, offset 63, 16bit)
Nov 10 17:53:21 ser0_paco kernel: (scsi0:A:2): 160.000MB/s transfers
(80.000MHz DT, offset 63, 16bit)
Nov 10 17:53:22 ser0_paco kernel:   Vendor: COMPAQ    Model:
BF03685A35        Rev: HPB6
Nov 10 17:53:22 ser0_paco kernel:   Type:   Direct-Access            
         ANSI SCSI revision: 03
Nov 10 17:53:22 ser0_paco kernel: Starting timer : 0 0
Nov 10 17:53:22 ser0_paco kernel: blk: queue f6e69818, I/O limit
524287Mb (mask 0x7fffffffff)
Nov 10 17:53:22 ser0_paco kernel:   Vendor: COMPAQ    Model:
BF03685A35        Rev: HPB6
Nov 10 17:53:22 ser0_paco kernel:   Type:   Direct-Access            
         ANSI SCSI revision: 03
Nov 10 17:53:22 ser0_paco kernel: Starting timer : 0 0
Nov 10 17:53:22 ser0_paco kernel: blk: queue f6e69618, I/O limit
524287Mb (mask 0x7fffffffff)
Nov 10 17:53:22 ser0_paco kernel:   Vendor: COMPAQ    Model:
BF03685A35        Rev: HPB6
Nov 10 17:53:22 ser0_paco kernel:   Type:   Direct-Access            
         ANSI SCSI revision: 03
Nov 10 17:53:22 ser0_paco kernel: Starting timer : 0 0
Nov 10 17:53:22 ser0_paco kernel: blk: queue f6e6de18, I/O limit
524287Mb (mask 0x7fffffffff)
Nov 10 17:53:22 ser0_paco kernel:   Vendor: COMPAQ    Model: PROLIANT
4L6I     Rev: 1.86
Nov 10 17:53:22 ser0_paco kernel:   Type:   Processor                
         ANSI SCSI revision: 02
Nov 10 17:53:22 ser0_paco kernel: Starting timer : 0 0
Nov 10 17:53:22 ser0_paco kernel: blk: queue f6e70018, I/O limit
524287Mb (mask 0x7fffffffff)
Nov 10 17:53:22 ser0_paco kernel: scsi0:A:0:0: Tagged Queuing enabled.
 Depth 32
Nov 10 17:53:22 ser0_paco kernel: scsi0:A:1:0: Tagged Queuing enabled.
 Depth 32
Nov 10 17:53:22 ser0_paco kernel: scsi0:A:2:0: Tagged Queuing enabled.
 Depth 32
Comment 4 Rubén Dután 2004-11-11 09:23:54 EST
Created attachment 106502 [details]
file messages
Comment 5 Tom Coughlan 2004-11-11 09:57:14 EST
There is a newer firmware version available for those drives.  

http://h18007.www1.hp.com/support/files/storage/us/revision/7113.html

No idea if that will help or not.

Under what circumstances do the "Saw underflow" errors occur?

Will you be able to try aic7xxx_old.o?

These are U320 drives on a U160 adapter.  Any chance you can try with
a U320 adapter (this will use the aic79xx driver, btw)?

Comment 6 Tom Coughlan 2005-09-19 09:00:12 EDT
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received the feedback we
requested, we will assume the problem was not reproduceable or has been fixed in
a later update for this product.

Users who have experienced this problem are encouraged to upgrade to the latest
update release, and if this issue is still reproduceable, please contact the Red
Hat Global Support Services page on our website for technical support options:
https://www.redhat.com/support

If you have a telephone based support contract, you may contact Red Hat at
1-888-GO-REDHAT for technical support for the problem you are experiencing. 

Note You need to log in before you can comment on or make changes to this bug.