Bug 138776 - gdm locks up when logging out from gnome
gdm locks up when logging out from gnome
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-10 21:36 EST by Tobias Schulze
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-30 17:17:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tobias Schulze 2004-11-10 21:36:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041003
Firefox/0.10

Description of problem:
I'm using Fedora Core 3 on a Dell Latitude C600 notebook with ATI
Mobility M3 graphics running with the r128 driver from X.org.

When I try to log out of a Gnome session the window, where to select
what i want to do now (log out, shutdown, restart) appears sometimes a
little bit delayed. When it shows up and I select "log out" the
selection-window disappears and nothing happens about ten to fiveteen
seconds. After that time mostly X or the whole system locks up. If
only X locks up, ps -ea shows X <defunct> and i can't kill -9
gdm-binary or X. If the system fully locks up, the screen gets black
and the lower half of the display becomes slowly milky white.

Similar problems are reported in bugzilla concerning Fedora Core 2 but
the solutions given (switch off DRI in xorg.conf or setting
AlwaysRestartServer=true in gdm.conf) do not help.

I found a workaround in using gdm-2.6.0.5-2 from Fedora Core 3 Test 3.
Once installed, the problem does not appear anymore.

Version-Release number of selected component (if applicable):
gdm-2.6.0.5-6

How reproducible:
Always

Steps to Reproduce:
1. Log out of Gnome
2.
3.
    

Actual Results:  In most cases X or the whole system locks up.
When X locks up, i can not kill -9 X or gdm-binary
When the whole system locks up, the screen gets black and then the
lower half becomes milky white.

Expected Results:  Log out in normal speed and showing up the gdm
login screen.


Additional info:
Comment 1 Ray Strode [halfline] 2004-11-10 22:44:27 EST
Hi Tobias,

The changes between 2.6.0.5-2 to 2.6.0.5-6 were relatively minor.  I
wonder if the problem stopped occuring by coincidence when you
downgraded.  If you reinstall 2.6.0.5-6 do you reliably get the lock
ups again? 

One change that may be the culprit is a line added to clean up gdm's
log file in /tmp on successful logout.

Did you tell the FC3 installer to setup SELinux?  If so, did you tell
it to use enforcing mode?

When you run

ls -laZ /tmp || ls -la /tmp

at a shell prompt, what does it output?
Comment 2 Tobias Schulze 2004-11-11 11:40:34 EST
Reinstalling gdm-2.6.0.5-6 seems to solve the problem.

I did about five clean FC3 installs on this notebook and it does not
make a difference if SELinux is enabled or not (concerning my problem).

At the moment ls -laZ /tmp does nothing because SELinux is switched off.

ls -la /tmp gives the following output:

drwxrwxrwt  12 root root 4096 11. Nov 17:29 .
drwxr-xr-x  23 root root 4096 11. Nov 17:26 ..
drwxrwxrwt   2 root root 4096 11. Nov 17:26 .font-unix
drwx------   2 root root 4096 11. Nov 01:31 gconfd-root
drwx------   3 foo  foo  4096 11. Nov 17:29 gconfd-foo
srw-rw-rw-   1 root root    0 11. Nov 17:26 .gdm_socket
drwxrwxrwt   2 root root 4096 11. Nov 17:29 .ICE-unix
drwx------   2 foo  foo  4096 11. Nov 17:29 keyring-EtUBWk
srwxrwxr-x   1 foo  foo     0 11. Nov 17:29 mapping-foo
drwx------   2 root root 4096 11. Nov 00:50 .mozilla
drwx------   2 foo  foo  4096 11. Nov 17:33 orbit-foo
drwx------   2 foo  foo  4096 11. Nov 17:27 ssh-bnKZxE2906
drwx------   2 foo  foo  4096 11. Nov 17:29 ssh-PXoPrl3060
-r--r--r--   1 root root   11 11. Nov 17:26 .X0-lock
drwxrwxrwt   2 root root 4096 11. Nov 17:26 .X11-unix
-rw-------   1 foo  foo  3207 11. Nov 02:09 xses-foo.0n1Tad
-rw-------   1 foo  foo  1107 11. Nov 03:46 xses-foo.2tyfR6
-rw-------   1 foo  foo  1616 11. Nov 03:02 xses-foo.7l1Rl3
-rw-------   1 foo  foo  1688 11. Nov 01:40 xses-foo.95nevx
-rw-------   1 foo  foo   467 11. Nov 17:29 xses-foo.c2IWhv
-rw-------   1 foo  foo  1503 11. Nov 00:40 xses-foo.cpvDRD
-rw-------   1 foo  foo  1196 11. Nov 14:44 xses-foo.CRg6Al
-rw-------   1 foo  foo  2179 11. Nov 01:20 xses-foo.LBR57Q
-rw-------   1 foo  foo  2675 11. Nov 01:31 xses-foo.mjXvuB
Comment 3 Ray Strode [halfline] 2004-11-11 13:07:29 EST
Hi Tobias,

So you can no longer reproduce the problem?

If the problem happens again can you try to set your X video driver to
vesa to see if that works around the problem?
Comment 4 Tobias Schulze 2004-11-11 14:14:55 EST
Tried it yesterday (setting X driver to vesa), didn't help.

I'll try this night another clean install and see if it helps if i
clean up /tmp by hand or simply re-installing gdm-2.6.0.5-6 without
the workaround with gd from fc3t3.
Comment 5 Ray Strode [halfline] 2004-11-11 14:28:25 EST
Thanks
Comment 6 Tobias Schulze 2004-11-11 16:14:13 EST
Reinstalled Core 3, same problem occured.
Run init 3, cleaned /tmp, init 5. Even a little bit slow but no more
lockups. Uninstalled gdm-2.6.0.5-6 && reinstalled same version, reboot.
Problem has gone for the moment but I'll keep an eye on this...
Comment 7 Rik Theys 2004-11-18 05:03:45 EST
Hi,

I have the same problem on Dell GX240 machines (tried it on 2
machines). On the GX240 the system always crashes completely (no
network, pressing the power button turns of the computer instead of
shutting it down). 

I've tried installing the 2.6.0.5-2 RPM from test3 but this does not
solve the problem. I'm not sure this is a gdm bug: the problem remains
even if I make XDM the preferred login manager (in
/etc/sysconfig/desktop).

The problem does NOT occur when I boot the system in textmode (init
3), login, start X, logout. It only occurs when the system is in init 5.

I've also tried a Fedora Core 2 installation (with all the latest
updates) in the GX240 machine and the problem exists also on core 2.
The kernel on core 2 is de 2.6.7 version (not the latest 2.6.8 update).
Comment 8 Matthew Miller 2006-07-10 16:15:07 EDT
Fedora Core 3 is now maintained by the Fedora Legacy project for security
updates only. If this problem is a security issue, please reopen and
reassign to the Fedora Legacy product. If it is not a security issue and
hasn't been resolved in the current FC5 updates or in the FC6 test
release, reopen and change the version to match.

Thank you!
Comment 9 John Thacker 2006-10-30 17:17:33 EST
Closing per lack of response to previous request for information.
This bug was originally filed against a much earlier version of Fedora
Core, and significant changes have taken place since the last version
for which this bug is confirmed.

Note that FC3 and FC4 are supported by Fedora Legacy for security
fixes only.  Please install a still supported version and retest.  If
it still occurs on FC5 or FC6, please reopen and assign to the correct
version.  Otherwise, if this a security issue, please change the
product to Fedora Legacy.  Thanks, and we are sorry that we did not
get to this bug earlier.

Note You need to log in before you can comment on or make changes to this bug.