Bug 138780 - after "yum update yum", yum fails
after "yum update yum", yum fails
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
3
noarch Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-10 23:42 EST by james
Modified: 2014-01-21 17:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-19 00:36:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description james 2004-11-10 23:42:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; Linux i686; U) Opera 7.54  [en]

Description of problem:
a subsequent "yum -y update" simply gives:

Traceback (most recent call last):
  File "/usr/bin/yum", line 8, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 51, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 245, in getOptionsConfig
    self.parseCommands() # before we exit check over the base command 
+ args
  File "/usr/share/yum-cli/cli.py", line 303, in parseCommands
    if not self.gpgKeyCheck():
AttributeError: YumBaseCli instance has no attribute 'gpgKeyCheck'

Or, without "gpgcheck=1", there is:

Setting up Update Process
Setting up Repo:  development
Traceback (most recent call last):
  File "/usr/bin/yum", line 8, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 68, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 381, in doCommands
    return self.updatePkgs()
  File "/usr/share/yum-cli/cli.py", line 766, in updatePkgs
    self.doRepoSetup()
  File "/usr/share/yum-cli/cli.py", line 62, in doRepoSetup
    repo.check()
AttributeError: Repository instance has no attribute 'check'





Version-Release number of selected component (if applicable):
yum-2.1.11-4

How reproducible:
Always

Steps to Reproduce:
1.yum update
2.
3.
    

Additional info:
Comment 1 Seth Vidal 2004-11-11 00:19:30 EST
you're updating to rawhide? 2.1.11-4 is from rawhide is that what
you're dealing with? 
Comment 2 james 2004-11-11 18:23:50 EST
I've been updating the Fedora Core 3 test series using yum.  Currently, 
"cat /etc/redhat-release" says "Fedora Core release Rawhide (Rawhide)", 
where "rpm -qf /etc/redhat-release" gives "fedora-release-2-rawhide".  
No, I'm not sure where that came from, though I have loaded packages 
from Core 2 "extras".

Running "yum update yum" for the "development" repository loads
yum-2.1.11-4, which gives the errors.  Running yum-2.1.11-3 works 
though.


Comment 3 Thomas J. Baker 2004-11-16 15:59:27 EST
I'm running rawhide on a system too. Yesterday I did a yum update yum
and then a yum update and everything went fine. Today, when I try to
run yum, I get errors:

[root@katratzi tjb]# yum update
Setting up Update Process
Setting up Repo:  development
Traceback (most recent call last):
  File "/usr/bin/yum", line 8, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 68, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 381, in doCommands
    return self.updatePkgs()
  File "/usr/share/yum-cli/cli.py", line 766, in updatePkgs
    self.doRepoSetup()
  File "/usr/share/yum-cli/cli.py", line 70, in doRepoSetup
    repo.getRepoXML()
  File "/usr/lib/python2.4/site-packages/yum/repos.py", line 465, in
getRepoXML
  File "/usr/lib/python2.4/site-packages/yum/repos.py", line 443, in get
  File "/usr/lib/python2.4/site-packages/urlgrabber/mirror.py", line
414, in urlgrab
  File "/usr/lib/python2.4/site-packages/urlgrabber/mirror.py", line
400, in _mirror_try
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line
595, in urlgrab
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line
527, in _retry
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line
581, in retryfunc
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line
703, in __init__
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line
747, in _do_open
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line
823, in _make_request
  File "/usr/lib/python2.4/urllib2.py", line 364, in open
    response = meth(req, response)
  File "/usr/lib/python2.4/urllib2.py", line 468, in http_response
    code, msg, hdrs = response.code, response.msg, response.info()
AttributeError: HTTPResponse instance has no attribute 'code'
[root@katratzi tjb]#

Since yum ran OK yesterday to do the update, I'm guessing that the
python updates it installed are what broke yum. (Looks like they broke
up2date too)
Comment 4 Paul Wayper 2004-11-18 20:14:46 EST
Also getting this error on Opteron machine x86_64 architecture.
Comment 5 Paul Wayper 2004-11-18 20:20:49 EST
BTW, This is a Fedora Core 3 machine, not Rawhide.  Up2date still
works, though.
Comment 6 Seth Vidal 2004-11-18 20:43:51 EST
post your yum.conf and the files in /etc/yum.repos.d/ and the results of
rpm -q rpm
rpm -q python
rpm -q rpm-python
rpm -q yum
rpm -q fedora-release

thanks
Comment 7 james 2004-11-19 00:10:27 EST
Sorry, I upgraded to Fedora core 3 base using yum-2.1.11-3.
After upgrading everything else, yum-2.1.11-4 seems to work fine.
Some missing dependency?

BTW, with "gpgcheck=1", "yum update yum" fails silently with:

 Downloading Packages:
 unsigned package //var/cache/yum/development/packages/yum-2.1.11-4.
noarch.rpm

Based on what I still have in /var/cache/yum/development/packages/, 
it looks like I would have had:
rpm-4.3.2-12
python-2.3.4-10
rpm-python-4.3.2-12
fedora-release-2-rawhide

"/etc/yum.repos.d/" would have been empty, and /etc/yum.conf would 
have been just:

[main]
cachedir=/var/cache/yum
debuglevel=2
logfile=/var/log/yum.log
pkgpolicy=newest
distroverpkg=redhat-release
tolerant=1
exactarch=1
retries=20
obsoletes=1
[development]
name=Fedora Core $releasever - Development Tree
mirrorlist=http://fedora.redhat.com/download/mirrors/fedora-core-
rawhide
Comment 8 Seth Vidal 2004-11-19 00:36:33 EST
okay - comment number 3 and 4 is not related to this bug - you need to
go read: 138535

comment number 7: yum isn't failing silently, you're requesting to
update yum but you're asking it to gpgcheck a package that is
unsigned. That's not possible and yum is telling you so.
since I'm not seeing the actual bug here I'm going to close this.

Note You need to log in before you can comment on or make changes to this bug.